Linking android apps to a tile

I am in the process of fully moving my kitchen tablet to using I had played with it a bit previously, but since my LG tablet died when setting up a new one decided to go with it all the way. I am on a Kindle Fire now using SharpTools and Fully Kiosk.

Pretty happy with how things are shaping up for me. I have a tile that we can use to bring up Spotify and that works great. I am trying to figure out how to bring up another app that is not on the helpful page here and wondered if anyone had tips on how to find intents to start up an app. The app is ChefTap. Have googled a bit but not having luck finding it. Probably won’t have anyone here that knows that particular app, but tips in discovering the intents would be welcome!

1 Like

Since you’re using Fully Kiosk Browser, here’s an approach that works well:

  1. Open Fully Kiosk Browser, slide out the left navigation and select Settings
  2. Under the Web Content category, switch Open URL Schemes in other apps on
  3. Under the Universal Launcher category tap Select Items to Show
  4. Use the Add Application button at the bottom of the screen to select the apps you want to run
  5. Once you have the apps added in the list, tap the pencil next to each one and make note of the App component
    Note: the format looks like the following:
  6. In create the Hyperlink using the intent format, making sure to replace <App Component> with the details from step 5 above:
    intent:#Intent;launchFlags=0x10000000;component=<App Component>;end

So following the above instructions, we’d find the final URL to be:


Here’s a screenshot from step 5 so you can see where the App Component is coming from. :smiley:


Wow thanks for such detailed instructions! I have one new link working and will get my others done tomorrow.

1 Like

This worked great! I am just getting my feet wet with Sharptools and find it exceptionally well designed and configurable. I have a whole home audio system (older Niles system). I added a August Wireless WiFi Audio Receiver WR320 to the receiver to enable streaming from my Spotify app. It’s an extra step but it works. If there is an easier or more direct way, please advise. Thanks!


Hello, I tried this, but it says app not found for intent? Trying to load an app that shows my cctv system?

It looks like @James is responding in your other thread. :slight_smile:

1 Like

How do I get it to stop trying to load a webpage?

@Roman_Gurule, what browser are you using and can you post the link you used to open the app here so we can better understand the issue?

It’s fully paid and the one Josh posted above. Just trying to figure the best way to open Spotify on my tablet. New window, same window or open in modal.

If the app intent url is correct, it will just open and switch to the Spotify app directly., instead of treating it like a web page.

I think it’s good now. Seemed to be a lag between what I was doing on the laptop and on the tablet.

On a side note, any direct integration with spotify yet?

Please note that the intent url above would only work within Fully Kiosk Browser (your tablet).

We don’t have any update in regarding to the Spotify integration at this point, but please vote in the following Feature Request to help us collect the interests. :grinning:

1 Like

4 posts were split to a new topic: Fully Kiosk - Quirk After Opening Android App

Hi! I tried this with the Zello Walkie Talkie app and I didn’t work. Why would that be? Could you perhaps try it on your end and see if it works for you? Thanks.

Welcome to the community!

What part didn’t work? Can you share some more details about what you’ve tried?

So I followed the steps you put above and entered the following into a hyperlink tile:


And each time I try to click on the hyperlink tile, it just says “Failed to start another app.”

Are you clicking the Hyperlink within Fully Kiosk Browser or another browser like Google Chrome?

I’m clicking the hyperlink within fully kiosk.

Can you share a screenshot of what your Hyperlink configuration looks like?

The 'x' in your post above appears to be an '×' (multiplication symbol). I’m not sure if that’s just the formatting from the community post or if your hyperlink actually has that same symbol. It must be a normal 'x' and not the multiplication symbol for it to work.

Otherwise the intent URL provided works fine for me in Fully Kiosk Browser:


As noted in my original post above, also make sure that you’ve enabled ‘Open URL Schemes in other apps’ within the Fully Kiosk Settings.

1 Like