Fire + TinyCam + Fully + Mixed Content

So, having the same issue. Finally got around to trying to fix the fact that on my newer FireHD tablet my Tinycam streams were no longer showing on Fully.

Oddly, on my older 2017 FireHD tablet, Fully shows the stream. Will need to check which versions of Fully are running on each, maybe one is auto updating and the other is not.

I switched TinyCam to HTTPS. Then changed the resources to point to the https address vs http.

But all I get is a blank tile now (have also set Fully to always allow mixed content).

Edit: Interesting, both my tablets are running the same version of Fully. So maybe it is not a “Fully” browser issue if one works on http while the other does not? Neither work with https.

Make sure to follow the steps mentioned above. You must have Mixed Content allowed and must use a workaround for the IP if your device is using Chromium 111 or newer (eg.

Fully Kiosk does not have its own browser engine. It uses the one provided by your tablet. So your 2017 is likely running an older browser engine and the Fire OS on your 2020 was likely updated recently (Amazon tends to bundle browser engine updates with the OS).

Unless you know what you are doing and have a valid SSL certificate, I wouldn’t do this. It’s more likely to make things worse if you enable SSL, but have an invalid SSL certificate.

Hmmm…not sure I am following. Do I have to install anything for to work? Or just adjust my address.


Do I simply switch off SSL on Tinycam, then insert:

Or do I have to install an open source component somewhere?

Just following up as I still can’t seem to get this to work.

Also, if I have one device not using Chromium 111, the other using it, will that cause issues using the thing or should both work fine?

I would suggest reading through some of the discussion above as there’s some good discussion about what the issue is, why solves it and how it works, and how to use it. is just a DNS server. In other words, it just resolves the ‘domain name’ to a local IP address. Nothing needs to be installed as it’s a fundamental part of how the internet works and hosts the wildcard DNS service for free.

If you can provide more details, we might be able to help.

Yes, if that was the original camera URL, then that sounds like the right adjustments. I would start with the basics though. Make sure you have a valid URL for your camera that opens directly in your browser without any login prompts or warnings about SSL errors. (It might help to try it in an incognito window as a test).

Once you have that known working URL, you should be able to convert it to the format and open it directly in your browser.

Once that’s confirmed working, as long as you have made the adjustment to Allow Mixed Content, you should be able to use the URL that you tested directly in your browser within a Media Tile.

Okay, so the below URL properly opens in a Chrome browser and displays the feed along with the “:warning: Not secure” message. Surprised as I didn’t think I would actually see the picture for whatever reason.

Even after I clicked “Allow insecure content”, I still have the warning message.

However, when I then insert the into the URL, I get the usual NXDomain error implying the domain doesn’t exist.

This site can’t be reached

Check if there is a typo in

  • If spelling is correct, [try running Windows Network Diagnostics](javascript:diagnoseErrors()).


We would really need the details to be able to help. Otherwise we’re guessing at lots of details that could impact things (like what the full URL you used for testing was).

Also, is there anything special about your network configuration? Especially things around DNS resolution? I would also make sure you can visit directly in your browser without issue. And you could try using the dash format instead:

Or one of the other providers mentioned above:

Again, the details would really help here. Especially a screenshot.

You shouldn’t have been prompted to Allow Insecure Content in Chrome if you were visiting the camera URL directly. If you did, that could be indicative of something wrong. Since you played around with the SSL settings, make sure you completely restarted TinyCam to make sure they took effect once those settings were reverted. Or try restarting your phone too.

If you are prompted in any way (in a fresh incognito tab), that’s likely going to cause an issue. For example, you shouldn’t see a login prompt and you shouldn’t have to explicitly accept insecure content.

Sorry, not sure what details I’m omitting. But…

Using TinyCam Pro with webserver enabled on a NVidia Shield, port set to 8083, is the address of the Shield.

Have resources set up in my dashboard with the URLs to various cameras (have 7 cameras on the TinyCam). For instance, is my front door camera.

The tiles work on my Amazon FireHD8 2017 tablet, but do not work on my Amazon FireHD8 2020 tablet.

I’m testing this on a laptop using Chrome.

Clicking on works fine on the desktop.

I tried all links above, get the same NXDomain error.

Nothing special that I can think of around my network/DNS setup.


No prompts for passwords etc, goes right to the image.

Something is wrong with DNS somewhere along the line if you are getting the DNS_PROBE_FINISHED_NXDOMAIN error in Chrome with all of the above examples.

The screenshot doesn’t look like an incognito window. If you were ever prompted for your credentials or accepted any prompts, the browser could be saving those. That’s why it’s important to try a fresh incognito session.

Incognito, no popups either.

Let me try from a non-work laptop to see if works.

Bingo… URL embedded link works fine from my home laptop. So probably a DNS or restriction somewhere my company puts on the laptops. Now to see if it works with Fully.

@Jordan_Welker, by chance did you figure out how to get Fully to work again? I seem to be having the same issue that you are where even adding in into the address doesn’t work.

I suspect that Jordan’s issue was slightly different as they mentioned that didn’t work at all for them and they had mentioned that in the context of Chrome. Without more details, it’s unclear what their configuration was though.

Fire HD 8 Test

I just tested on a Fire HD 8 Plus (10th gen) with the version details shown in my screenshot below and it worked for me.

  • It was showing Fire OS installed from February or earlier. After that, I went through a ton of updates manually.
  • Unfortunately, I forgot to check the Webview version with my original test, but you can see the version details in my screenshot below.
  • You can access the ‘Device Info’ from my first screenshot within Fully Kiosk Settings → Other Settings (bottom) → Device Info (bottom)

Have you gone through these steps, noting the results of each, to help narrow things down?

Desktop / Laptop on Chrome (if available)

  1. Test the camera URL directly in your browser:

  2. Test the URL directly in your browser:

  3. Test the URL within a SharpTools Media Resource
    (SharpTools User Page > Manage Resources > Media)

Fire Tablet (Silk Browser)

  1. Test the camera URL directly in your Silk browser:

  2. Test the URL directly in your Silk browser:

  3. Test the URL within a SharpTools Media Resource
    (SharpTools User Page > Manage Resources > Media)

Fire Tablet (Fully Kiosk Browser)

  1. Test the camera URL directly in your Fully Kiosk browser:

  2. Test the URL directly in your Fully Kiosk browser:

  3. Test the URL within a SharpTools Media Resource
    (SharpTools User Page > Manage Resources > Media)

Sorry just getting back to this.

Just tried it on my 2017 Fire HD8 tablet.

The link opens up fine in the Silk browser.

It won’t open in the Fully browser…

The standard camera URL works fine in the Fully browser.

Have to try it on a non work laptop as well.

Also, the link works fine on my iPhone in Safari, not in Chrome.

Tried it on a non-work laptop. Same issue, Chrome and Firefox give the “We can’t connect to the server at” error.

So it works on Safari and Silk, but not Fully, Chrome or Firefox. Could have sworn it worked on another one of my personal laptops but can’t recall which it was.

Unfortunately, I’m unable to help without the details.

It’s really important to include the results of each step along with the details of any error messages (screenshots preferred). And in general, it’s important to include details like version numbers, device make/model, and any other relevant details about the configuration or testing.

As a free user, we try to offer as much support as we can through our community and documentation. Providing these details will enable both us and the community to assist you more effectively.

I’ve tested each of these steps on a variety of new and old devices and I’m not able to reproduce the issue. The DNS_PROBE_FINISHED_NXDOMAIN issue mentioned above is clearly a DNS / networking issue. It’s not clear exactly what error messages you were seeing when things weren’t working with some of your recent tests but “We can’t connect to the server at XXX” sounds like a networking error.

That’s part of the reason I asked for result of each of the steps above: it starts with a fundamental validation of network connectivity to your camera, then tests which should only be a difference in DNS resolution, then tests it as an embedded resource which is where most browsers get the most finicky.

Okay. First series of pictures is all on Silk Browser.

Top right on dashboard is driveway stream. Rest are all not on In Silks case using the sharp tools dashboard it does not show either or direct URLs.

Next is Fully. Again, Top right on dashboard is driveway stream. Rest are all not on

Versions of Tablet and OS.

Chrome laptop:

That looks like a DNS issue. What happens with the traefik and versions?

Just curious, but if Silk works for but Fully won’t on the same tablet, doesn’t that rule out a DNS issue?

Unless each browser allows you to change DNS settings which I don’t believe is the case?