Google Chrome - Mixed Content - Media Not Showing

What type of device is it on? It’s actually changing in the upstream Chromium project that Google Chrome is based on.

Fully Kiosk uses the device’s “webview” to display pages. On Fire Tablets, this likely won’t be an issue as their WebView implementation tends to be a few versions behind and doesn’t get updated frequently.

On a modern Android device with Google Play, the web view gets updated automatically through the Play Store just like an app would. And Android’s webview is based on Chromium so it will inherit these changes at some point.

It’s an Amazon FireHD8 7th Gen I think. Might just try a reboot… Was working great literally until a couple days ago!

I had this issue as well, affecting my camera streams that come from a server on my local network. Interestingly, when I switched from using the server’s hostname to its local IP, the streams began working again. I did not do any of the workarounds above.

1 Like

2 posts were merged into an existing topic: Media and Thermostats

A post was split to a new topic: Cameras and saved passwords

As of Chromium 111 – which is the engine behind many modern web browsers like Chrome, Edge, Opera, and more – a bug seems to have been introduced which breaks the ‘Allow Insecure’ option which is used for allowing mixed content when used with a local IP address for your media.

Using a Domain → IP resolver that can help with this in many cases. You can append to the IP address to get a valid domain.

There are also several other similar services available on the web if you prefer one of those (eg., They use the same approach where you add the service domain, such as, between the IP address and the port in your URL.

The only data sent to domain resolvers like is the host name (eg. for it to resolve the IP address. See the below reply for an explanation of how it works.



Some users have chosen to download an older version of their preferred browser, from before this bug was introduced, and disable auto updates so they can continue to use their image feeds.

For example, one user has documented how they downloaded an older version of Opera and disabled auto updates.

Please note that this Chromium bug also affects modern Android devices. Community members have suggested that the same general approach of rolling back to an older version works.

Uninstall the System WebView in the Google Play store so it rolls back to an old version. You can stick with that or download version 110 from a site like APK Mirror. --Austin

I’ve also posted a reply in the Issue Tracker from the Chromium with a sample reproduction, so hopefully the Chromium team will pick it up from there.

1 Like

So is there anything Sharptools can do internally to support this natively, A feature request? Even if they fix this chromium bug, past experience tells me things will change/update again down the road and it will go down again.

Perhaps this is above my pay grade, but I don’t understand how works.

Is this something that needs to run on my own server on my local net? Or is this an outside service that I can reference?

My dashboard does go straight to an IP address (…) I don’t mind having a DNS server on my network, but is that what is?

It’s just a DNS server. What’s unique about it is you can enter any IP address in the format and it tells your browser to open that page from the IP address you mentioned.

Normally, DNS is used to resolve human friendly names to a particular IP address on the internet. For example, would map to a particular public IP address on the internet and DNS is what takes care of converting that domain name of into an IP address so your browser knows what to talk to.

Normally, you wouldn’t point a domain name to an internal IP in your home, but it’s something you might have experienced if you work for an enterprise. Oftentimes enterprise organizations will have their own internal DNS servers that your computers automatically connect to for name resolution which means the company can create names like that might only work inside your corporate network since they point to local IP addresses. At the same time, they could have stuff like on their public DNS that points to public IP addresses that you could access even from your home (of course, this is just an example and your company might choose to keep their SharePoint servers internal only).

So nothing (other than the DNS resolution) is running through or similar services. Your browser is still connecting directly to your local camera. These services are purely providing name resolution for IP addresses as a public service.

To support what exactly?

The new update to chrome has also blocked use of streaming to cameras, unfortunately, i found firefox is the only web browser that will allow those connections, its due to the way the ip address is written. For example it does not like or how ever you type it unless it is a digital signed certificate which most ip cameras and dvrs will not have.

I’m using an older tablet, with I believe Android 7, which uses the webview nested inside the Chrome app.
I installed Firefox, removed Chrome and now my camera’s work again.

Hope this gets fixed before Firefox makes a breaking update. Or is this something to stay for good? I don’t feel like doing all the https stuff, I already stretched my knowledge with VPN and automatic stay connected with changing IP’s.

Will this work?

1 Like

Did google start blocking this again? I allowed mixed content but i still cant get it to work.

Check out this post as the Chromium 111 update may be impacting you. It includes some workarounds…

Google Chrome - Mixed Content - Media Not Showing - #9 by josh

I just started having this issue; image shows in manage resources, but not on dashboard. https was disabled and mixed content was enabled in fully kiosk. i even tried using https and get the same issue. this is a new fire tablet 8.

If it works in managed resources on the same device and browser, then it should work on the dashboard as well as they display the media resource the same way.

One difference on the actual Media Tile is if you have the Autorefresh enabled. When the media item first loads, it’s exactly the same as the Manage Resources tab… but once the refresh interval occurs, it will append an arbitrary URL parameter as a cache buster technique.

Since you mentioned that you already have the setting to allow mixed content enabled in Fully Kiosk, I would pay particular attention to the Chromium 111 bug mentioned above as many modern web browsers are based on that… check the reply above about using as a workaround.

Edit: If you are using Blue Iris, you might also check this post about embedding Blue Iris streams in a much more efficient way.

I misunderstood the workaround and thought it involved adding things or creating an account of some sort. So tried the much more efficient way, but that bothered me you can’t make it full screen. I really liked you could see all camera’s in 1 tile, but tapping a screen didn’t make it large enough.

So then I looked at the again and that was easy, just add it to the IP and done :sweat_smile:
At least now my tablet can simply update instead of running an old webcore. That’s how I used to do it, but suddenly my tablet decided to update anyway and broke it again.

1 Like

Still having the issue - mixed content set to always allow on fully and origin ip added to chrome flag. Video loads in browser and media resources but not fully kiosk. didnt work (broke preview in media resources). Anything else I can do on Fire tablets?

1 Like

Fully kiosk must have just recently updated to chrome 111. If anyone has a link to an older full kiosk I’ll take it but for now, Thanks! solved my pic from my camera streams but to access my camera streams in the ip address I have my user and password for the camera, how secure is as secure as sharptools or actiontiles I suppose

Edit: As jordan stated video doesn’t work but I did find old apks so I’ll try to side load an old full kiosk browser