Fire Tablet with Fully Kiosk Browser occasionally set to lowest dim level

I am have a problem with sharptools on my Fire HD 8 with Fully Kiosk Browser. After 2 or 3 days the brightness on my Fire HD gets turned down to the lowest setting and sharptools is no longer on my dashboard screen it is on the account screen. I am not sure where to start troubleshooting. Has this happened to anyone else?

It sounds like Fully Kiosk Browser is crashing and recovering. Are you running any other apps on the tablet? And is the tablet running stock Fire OS or has it been modified to run Google Play / Google Play Services?

For the second part about SharpTools being on the account screen, be sure to set your Start URL to the full URL of your dashboard. That way when Fully Kiosk Browser recovers from a crash, it would load your desired dashboard by default. You can find the setting under Fully Settings > Web Content Settings > Start URL

And it should be something like:

https://sharptools.io/dashboard/view/xxxxxxxxxxxxxxxxxxxx?kiosk=true

I have not rooted the Fire HD if you are asking. I have the stock Fire OS apps and I have installed Google play / services following the instructions here: https://www.youtube.com/watch?v=P5e9PZpRrZo

I just had sharptools.io as the URL so I have changed it to the dashboard URL so that issue should be resolved.

Is there any way to determine why the Fire HD is crashing?

All the Fire tablets that I’ve installed Google Play on start to get tremendously sluggish after a couple days. Whereas tablets that were opened fresh from the package and had Fully installed (and no other tweaks) run nice and fast.

Is there a particular app or feature you were trying to use that requires Google Play Services? I would generally recommend trying to keep the Fire tablets as close to stock as possible as they are already somewhat performance limited (though a great bang for the buck!).

You can find a version of Fully Kiosk Browser that is optimized for Fire tablet devices directly in the download box of the Fully Kiosk website:

https://www.ozerov.de/fully-kiosk-browser/#download-box

image

If you don’t need Google Play Services, you might start by removing that / reverting to factory defaults. If that doesn’t help, you might reach out to the Fully Kiosk Browser developer to see if he has any further tools for troubleshooting:

info@fully-kiosk.com

At the very least, it might be helpful for him to understand the issue with the dim level not recovering. Perhaps he could add a feature to recover the dim level properly.

I had experienced the significant sluggish when Google Play/services were loaded on my FireHD 10" as well. Factory reset and keeping it clean (nothing else installed except Fully Kiosk for Fire OS) is the way to go for me.

I used play to install fully. I don’t know why I did not install it from the developer site. I was also going to install tasker. It sounds like it will be best if I factory reset.

Thank you @josh and @James for you input.

1 Like

I forgot to ask earlier. Are there any recommended settings you have for Fully to work efficiently?

I do not have any performance related settings applied in Fully.

The main settings I usually double check that I’ve set in Fully Kiosk Browser are:

  • Web Content Settings
    • Start URL: set to my full dashboard URL with ?kiosk=true appended
    • Enable Popups: on (optional)
    • Open URL Schemes in Other Apps: on (optional)
  • Web Auto Reload
    • All settings default at 0 / off - events are automatically pushed to your device and having the page auto refresh periodically can actually introduce more of a burden rather than help things
  • Advanced Web Settings
    • Enable JavaScript Interface: on (optional)
      • Adds a convenient ‘Set Start URL’ option within the … menu of the dashboard list
    • Keep Screen On while in Fullscreen Mode: off (optional)
      • If you are running a newer version of Fully Kiosk Browser, SharpTools will prompt you about this setting when you first try to use the fullscreen icon in a dashboard
    • Fake User Agent String (optional)
      • You can use this to emulate an iPad or other device to enable Google Login within Fully Kiosk Browser. Our recommendation is to use a linked email/password or phone login though.
  • Screensaver (optional)
    • I usually set mine to go to a dark screen after a minute or two.
      • Some people like to build a specific dashboard to use as their screensaver with just a clean image as a background and maybe a calendar/news/weather.
    • Screensaver Timer: 60 (or whatever value you want)
    • Screensaver Wallpaper URL: fully://color#000000cc
    • Screensaver Brightness: 1
  • Device Management
    • Keep Screen On: on
    • Screen Brightness
      • I just noticed this setting - I wonder if it would help with the dimming issue you experienced. Maybe give it a try? See the post below for more details.
    • Launch on Boot: on
  • Motion Detection (optional)
    • These settings pair up well with the screensaver so that your tablet will automatically wake when you walk in front of it. Though it should be noted that the camera will have a hard time seeing you in the dark, so you could use a motion sensor with your hub to wake the device if you prefer.
    • Enable Visual Motion Detection: on
    • Exit Screensaver on Motion: on
  • Remote Administration
    • Enable Remote Administration: on (optional)
      • If you want to be able to control Fully Kiosk Browser from your smart hub, there are device handlers for SmartThings and for Hubitat.

Make sure to not use the screen off features on a Fire Tablet unless you don’t mind having to manually unlock the screen (eg. do not use the ‘Motion: Turn Screen Off in Darkness’ or ‘Device Management: Screen Off Timer’ or ‘Power: Sleep / Force Screen Off’ type features). Most people use the Keep Screen On setting along with a black/dim screen as the screensaver to workaround this on Fire Tablets.

Edit:
User @Jeff_Fourman has also indicated that enabling the Stay Awake setting under the Fire tablet developer settings can help prevent issues with the brightness getting stuck at a low value.

1 Like

@josh thank you. This will be very helpful.

By the way, somehow I haven’t seen much talk of this in the home automation boards, but the fire 7 (5th and 7th gen) and 8 tablets are 100% unlockable/rootable now. I just finished installing a custom Android ROM on both of my 2017 fire 7s, and it’s perfection. No more black screensaver for me. They turn off in darkness and wake on motion, no lock screen.

Only catch is, you have to have access to a Linux computer (raspberry pi will do great) and you have to pry the back off the tablet to short a pin on the mb during part of the process. Lol it sounds worse than it is, really. :joy: My second one literally took 5 minutes, most of which was just watching the 2 scripts run.
I now have TWRP and can load any ROM I choose just by holding volume down+power and installing from sd. Wouldn’t hesitate one minute if people are interested in getting the best auto-off-on experience possible.

In my case, the black screensaver was a no-go for the bedroom. Even that amount of light was too much, and not being able to trigger it with darkness meant having to wait until the timer set the screensaver… Not good enough for me. I decided to check again in the hopes that someone had figured out a hack, and lo and behold! They have indeed!

1 Like

I ran into the same issue as listed above. My situation was a little different. I had a brand new Fire 8, made no changes to the base software, installed Fully Kiosk Browser by the instructions, and used the Fire 100% to display Sharptools. After about two weeks, the brightness went to about 5%.

What I finally figured out, is that some how my Fire was going into adaptive display mode and adjusting the brightness to 5%.

About once every two weeks this will occur. I simply go to settings>display, turn off adaptive brightness, click on brightness move the slide to full.

It is typically stable for a few weeks then I just repeat.

2 Likes

I wonder if this could be automated with one of the Fully Kiosk Browser device handlers / drivers.

There’s a setScreenBrightness(level) command in the driver. I’m wondering if you could just periodically call that command to adjust the brightness back to 100%.

If I remember correctly, this was happening to me when I had a screensaver setup which would dim down really low whenever there was no motion. It seemed like Fully Kiosk was crashing and recovering while it was in screensaver mode (eg. the brightness was set low)… and when it recovered, it snapshotted the low brightness as the ‘return’ value.

It may be worth a shot if someone wants to tinker with it. You may even first want to use the stopScreensaver() command before adjusting the brightness in case that has any impact. :slight_smile:

After using Josh’s settings in post number 8 the brightness would no longer change for me. I am sure it was the screen brightness under Device Management.

I had the same issue where every couple of days, the Fire HD 8’s brightness would dim to 5%. I changed two settings and am not sure which one was the fix… 1) Set the Fully Kiosk Screen Brightness under Device Management to 190ish. 2) Enable Developers Options on the Fire HD 8 and enable the “Stay Awake” setting. Fully Kiosk will still “sleep” according to your Screen Saver settings.

To enable developers mode on the tablet… Settings>Device Options>About Fire Tablet>Tap the SN 7 times.

1 Like

Ah, I forgot about the the Device Management → Screen Brightness setting. I saw it when creating the post above with all the settings I generally use, but didn’t go back and try it. I just gave it a try and it does seem to set the brightness back to whatever value you specify whenever Fully Kiosk Browser opens.

Here’s the test I did:

  1. Exit Fully Kiosk Browser
  2. Manually adjust the brightness to a low value using the drop-down shade
  3. Reopen Fully Kiosk Browser and the brightness went back to the setting under Device Management → Screen Brightness
  4. Wait several seconds for the screensaver to kick in and the brightness went to the level specified under Screensaver → Screensaver Brightness

I’ll have to wait and see what happens when the app crashes and recovers… but it sounds like it’s working for @Jeff_Fourman!

Important: One thing to note is that the Fully Kiosk Brightness values are 0-255. So for 100% brightness, you’d need to use 255 as the setting.

Target Brightness Fully Kiosk Brightness Setting
100% 255
75% 192
50% 128
25% 64
5% 13

I also saw the following tip on the Fully Kiosk Browser website when I was looking for more details on what the Device Management → Screen Brightness setting does. This seems to match up with what @Jeff_Fourman experienced as well. I’ve noted his feedback around setting the Stay Awake option under the device’s developer settings in the original post above.

Can I use Fully Kiosk with an Amazon Fire tablet?

4. Some users reported screen brightness issues where the brightness is not set/reset properly when using the brightness settings in Fully Kiosk. If you encounter this issue please check that Keep Screen On option is enabled in Fully Kiosk. Otherwise Android can mess up things.

I found my Fire 10 HD also going into a very dim setting lately. I have adaptive brightness set to off. It seems to happen every couple days or so.