Dashboard not refreshing

My dashboards have stopped refreshing. They sometimes do, but most of the time don’t. Sometimes it is so bad that even the “Command sent” popup remains on the dashboard and fails to disappear. Often the tiles don’t update after pressing them and stay as if the tile is greyed out. If I refresh the browser, the tiles get updated and display the true state of devices. This happens both in Chrome and Firefox (on Windows PC). If a device’s status is changed by another source (e.g. Hubitat app), the change doesn’t show most of the time in the dashboard until the webpage is refreshed.

I’ve seen that it was suggested to another user who had this problem to re-authorize the locations. I tried this, and it helped somewhat, but after a few hours, the problem reappeared.

Some more background information: I have 2 Smartthings hubs, three Hubitat hubs, and one instance of Home Assistant authorised in Sharptools. One of the three Hubitat hubs is at my holiday home and died (went offline) about 6 weeks ago. I’ll only have access to that hub at the end of this month. Because it disappeared from my Hubitat account, I cannot refresh the hub’s authorization. I do not want to delete the hub from Sharptools, because I’m not sure if the hub died. Hopefully, it is just the power supply that died, and I do not want to lose my dashboards by deleting the hub before I’m sure it has died. However, the issue with dashboards not refreshing only developed about three weeks after that hub went offline.
The second Hubitat Hub is a C7 which I migrated to the C8. I tried to disconnect the C7 from Sharptools, but I get an error if I try to the C7 (To delete the hub, I click on the three dots next to the hub’s name and choose “Disconnect” at the bottom of the page.)

The problem with dashboards not refreshing started before I migrated to the C8 hub. In fact, I was hoping that the issue would go away as part of the migration process, but no such luck.

If I have to guess, the problem started after I started adding Super and Custom Tiles to Sharptools. I was worried that the tiles were overloading the dashboard and removed them from dashboards as part of my troubleshooting, but that did not make a difference. (I did not delete the Custom and Super Tiles, I only removed them from all dashboards.)

What else can I try to get the dashboards to refresh? Thank you.

Thanks for posting and sorry to hear that things aren’t working as expected.

This clue gives me the most concern as it seems to indicate something more fundamental happening with the browser if those are getting stuck.

What plugins/extensions are installed in Chrome and Firefox? Can you think of any other sort of changes to the PC around that time (Network Security / Antivirus / OS Updates / etc)?

The hub being offline shouldn’t cause these kind of issues. As for revoking access to the migrated C7, the hub has to be online and you need a valid authorization token in SharpTools in order to disconnect it. The migration article covers has some insights - the short version is you can either bring the C7 hub back online and reauthorize it so you can properly disconnect it or you can email support and we can manually delete the location for you.

Do you have other devices that you’re able to test the dashboards on? For example, could you test on a phone or tablet and do those have the same issues?

Can you think of anything else that might have changed just before the issues started occurring?

Thanks for your response.
Your questions have caused me to re-think the symptoms, especially your question regarding trying other devices.
First thing is that with further testing, I realized that I no longer have the issue in Chrome, only in Firefox. I prefer to use Firefox because it allows me to show camera feeds in the dashboard, which is not possible in Chrome as far as I know. (I have never been able to get a camera feed to work in Chrome,)
I installed Firefox on an Android phone (Fold 3) to see what happens. Firefox on Android doesn’t have the problem.
The Firefox issue is present on two different Windows PC’s running Windows 10. On my week old Windows 11 laptop, the problem is also present in Firefox:

I tried to turn on the 3 lights indicated with the red border in Firefox on the laptop to check if it also has the issue. As you can see, the three tiles remain a lighter shade, instead of turning dark blue to indicate the lights are turned on. The “Command Sent” notifications remain on the dashboard (even after 3 minutes), until I refresh the page.

Just checked, the problem also doesn’t occur with MS Edge.

So it appears to be a Firefox issue? (I feel stupid that I’ve not figured this out weeks ago, especially since I spent lots of time configuring the custom tiles in dashboards, only to afterward remove them from all dashboards because I was convinced they were the cause of the problem.)

Unfortunately, I prefer Firefox for the reason explained above.

What extensions or plugins are installed in Firefox?

You likely need to adjust the Mixed Content settings in Chrome as noted here:

Not sure what the purpose of these plugins is. I disabled both and restarted Firefox. Unfortunately, it made no difference.

Thank you for the info regarding Chrome.

I’m going off-topic, but I am eager to find a solution to my issue, even if that would mean using Chrome to view the dashboards in the future.
I changed “Insecure content” to allow in Chrome, but the security camera feed still doesn’t show in the tile setup or the dashboard when using Chrome. What is strange is if I use the same url I use in the Media Tile setup directly in Chrome, the video feed of the camera works fine.
I’m using Tiny Camera web server as the source for the camera feed. Https is not enabled in Tiny Cam, because according to this post, that will in any event not help. (Just to be clear, the same url works fine in both the Media Tile setup and in a dashboard.)

Can you share an example of what the URL looks like? And the exact-same existing Media Resource is viewable in the resource editor and in a dashboard in Firefox without any other changes?

Have you tried opening the Chrome Developer Tools (F12) and view the Console while you try to edit the Media Resource to see if any errors or warnings are logged that might provide more clues.

For Tiny Camera Pro, I use
Using Blue Iris, also works with :

Yes, the cameras work with any of the above links in Firefox, e.g.:

If I open the same media source in Chrome without making any changes, it results in this:

Regarding dashboards not opening in Firefox: I added a new media tile last night when troubleshooting the issue, and for a few minutes, the dashboard was updating. However, after about 15 minutes, I noticed that it had stopped updating again. Probably just a coincidence and unrelated to adding the tile, but I thought I’d mention it.

I’ll report back on your suggestion about opening Chrome Developer Tools.

Thank you

Edit: I looked at the Media Resource page with F12 enabled. I don’t know what I should look for, but I don’t see anything that looks like an error message. Don’t know if a screenshot would be of value?

@Robert_Kastelic reached out last evening and mentioned that the latest Chrome update seems to have broken the mixed content setting: Allow Insecure. They indicated that they reverted to a previous version of Chrome (and disabled auto updates) and it resolved the issue.

I’m able to reproduce the issue on Chrome 111 as well, but I have not tried reverting to an older version of Chrome.

I would note that you can enable the SSL setting in TinyCam, but you’re trading off the ‘mixed content’ issue for an invalid SSL certificate issue. You can manually add the SSL certificate to your trust store, but we generally just recommend avoiding this altogether and just using the Allow Insecure option in Chrome as managing SSL certs tends to be more complicated than most people are interested in tackling.

Of course, another approach is to install a valid SSL certificate for the camera streams. In the same vein as certificate management, this just tends to be more complicated than the average person is interested in tackling. That being said, I personally run all my services behind Caddy with is an HTTP proxy with automatic SSL management. It was a bit of a learning process for the initial setup, but I tend to enjoy those kind of challenges. :slight_smile:

Thanks Josh, much appreciated. The easier option seems to be to sort out the issue with the dashboard not refreshing in Firefox. :innocent:

The challenge is I don’t see any clues as to why Firefox would have started having issues all of a sudden. And it seems like a pretty catastrophic failure where it stops receiving updates and other parts of the app, like removing the toast notifications, start locking up.

Have you tried installing an older version of Firefox (from before when the issue started) to see if it was introduced with a particular Firefox version?

I will try that. My troubleshooting has been focused on finding the tile that was causing the issue because I believed that is what was causing the issue. But as I have indicated, I’ve deleted all custom tiles and the problem remained.
Am I correct that it is not possible to create a backup of a dashboard? (If that was possible, I could delete a few tiles at a time to see if I can find an offending tile, but I would hate the idea of destroying dashboards to troubleshoot the issue if it is not possible to recover them afterward)
I’ll report back after testing an earlier version of Firefox.

You can make a copy of a dashboard to save as a backup. From the main dashboard list, tap the ... next to a dashboard and choose the Copy option from the menu that pops up.

I uninstalled the current version of Firefox and tried version 102.6 which was released towards the end of 2022. (My issues started about 3 weeks ago.) When installing Firefox, I created a new profile and did not sign into Firefox to prevent any plugins, bookmarks etc, from syncing. I did this on both my Windows laptop and PC.
I copied the main dashboard. The dashboard includes devices from Smartthings, Hubitat and Home Assistant, plus a media tile. I removed all devices other than the Hubitat devices from the original dashboard. That did not make a difference.
Some other things I’ve noticed that may be relevant:
Sometimes, when saving a dashboard in Firefox after editing it, the Save etc buttons turn grey once “Save” is clicked and the dashboard is not saved, and the page becomes unresponsive. The only way to get out of this state is to refresh the dashboard webpage.
I experience the same issue on 2 PC’s and a laptop.
I’ve mentioned that the “Command Sent” message remains until the page is refreshed. Even after switching to a different dashboard (with a dashboard tile), the messages remain. The only way to get rid of the messages when this happens is to refresh the web page.

Any other suggestion on what the issue could be?

Another user mentioned that they’ve temporarily switched to Opera until Google fixes the issue with the Allow Insecure (mixed content) setting not working in the latest version.

I’m hesitant with that approach as Opera is based on the Chromium project now too, so at some point they’ll likely update their underlying engine as well, but it could be an option in the meantime (especially if you disable auto updates).

It’s not clear what the issue is. Since I don’t have other reports of this, I am suspicious that it could be something specific to your account, but there aren’t specific clues pointing to a particular issue.

You would be looking at the console tab. If there were any error messages, they would usually be shown in red. It’s possible that it’s not an application error per-se though and something else is going on with Firefox that’s causing these issues with your account.

1 Like

Thank you @josh !! Opera is the solution. The dashboard updates as it should and it shows local camera feeds.

What I have noticed, and I suspect it has something to do with the Firefox not-refreshing issue, is that as I was adding Custom Tiles back to the dashboard, the interface slowed down. Linked to this is that when customizing a hero tile, the drop-down list fails to show when clicking on the arrow, or it shows for a split second and disappears:

Thinking back, I noticed the same in Firefox when I was adding/editing more complicated tiles.
For now, my issue has been resolved with the Opera workaround. Thanks again for your assistance.

The Opera party did not last long. Although it was working fine on my laptop, when I installed it a few days later on two other PC’s, I had the same issue as with Chrome, even though I was using the same installer file on all PC’s. Eventually, I figured out that the installer exe downloads and installs the latest version during the installation, and as a result, later versions of Opera were installed on the other PC’s. Opera was updated in the last few days, causing the security camera not to be displayed.
It appears that the latest version of Opera displaying video is the version that can be downloaded here: Index of /ftp/pub/opera/desktop/96.0.4693.80/win/
To prevent Opera from updating to the latest version: [Solved]How to turn off auto update | Opera forums

1 Like

Regarding the issue on the bug introduced in Chromium 111 that breaks IP Camera images over HTTP, make sure to follow the Mixed Content thread as updates are being posted there:

:link: Google Chrome - Mixed Content - Media Not Showing - #9 by josh