Weather Tile - Open Weather - Current and Forecast

What Fire OS version are the Fire Tablets running? The tile is using a number of latest generation JavaScript features, so it requires a relatively modern browser.

Fully is telling me: 7.1.2 (Fire OS) (SDK 25)

I would have thought that would be new enough. It’s equivalent to Android 9, but it’s likely the WebView is a bit outdated as Amazon uses their own version of it. I’ll take a look and see if I can figure out which APIs the device doesn’t support and see if I can work around them.

If it helps, Fully reports the Webview version is 70.0.3538.110

Your help is appreciated!

Interesting. My Fire HD 8 Plus (10th gen) is running Fire OS with a much newer Webview version at 96.4664.92.25 and it shows the custom tile fine.

Either way, I updated the custom tile to remove a bunch of modern JavaScript features and replace them with older approaches that are more compatible with older browsers. You should be able to update your Custom Tile using the steps above and try it again.

1 Like

Working perfectly now - thanks for the top notch support!

1 Like

Tip: If you want to remove the gradient and use your own defined tile style, just comment out the stylesheet line as indicated by the code comments:

It will result in a tile like this (showing my custom style):

1 Like

Another tip… for those of you using Kiosker of iPad (probably the most equivalent to Fully Kiosk Browser in Android), not only you should add “” as an allowed domain, you should also add the “” domain in the Kiosker settings as the custom tiles (like this open weather custom tile) run on a separate space.

I was not able to see the weather tile while running Kiosker, but was with Safari. @josh pointed this out to me and once I added that second domain, worked like a champ.

1 Like

I find it a bit strange that Webview doesn’t update automatically on the Fire tablets when available. I have three Fire HD10’s. One of the two 9th generation was on Webview version 96 while the other and an 11th generation were on Webview version 98. Regardless of the Fire OS version updating and all updates being installed, Webview seems to remain at the version it was when purchased. It can be upgraded manually but it’s a faff on finding the correct file.

1 Like

I have a Samsung Galaxy View tablet running my current dashboard. Would love to use this custom Icon but it is running Android 5.1.1 and won’t upgrade. Any way I can make this work on that version?

What browser are you using?

Chrome…should I try something else?

I would have thought that Chrome could be updated to a new enough version. What version of Chrome is it? You could also try Firefox.

I’ll also try things out on an Android 5.1.1 device. I suspect there’s a few more things I could port over for older browsers.

Chrome is 43.0.2357.93 And Java is V84.3.61.22

Will try firefox

It works in Firefox. Now I just need to test everything else. Thanks for quick assist.

1 Like

I pushed some changes to the tile which make it compatible with even older browsers than before. I tested on Android 4.4 and that’s a really old OS at this point (~10 years old!).

For anyone who has a device that old, I would strongly recommend loading a modern version of Chrome or Firefox as you’ll get better performance out of the device… and at 10+ years old, I would consider a new device as that’s getting pretty ancient for a tablet. :slight_smile:

Does anyone know what am I doing wrong? Tried multiple API keys, locations, browsers, reimported the code - always the same result:

What type of browser(s) are you using and have you waited an hour since generating the API Keys? At least for new accounts, Open Weather sometimes takes an hour before new keys go live.

Also, step 3 is really important, do not edit any of the settings when you are still in the developer tools as part of the Custom Tile import process. You should immediately save the custom tile and then go add an instance of it to a dashboard. Only once it’s added to a dashboard should you use the ... menu on the tile (while in edit mode on the dashboard) to edit the tile configuration and add your key there.

If you think you edited the custom tile itself, you can take a look at this post for what issue looks like and the post immediately after it for steps on how to correct it.

I tried Chrome, Opera and Fully Kiosk on latest Fire tablet. I did not change the code, and added the key from ... menu as you suggest. API keys where active for couple of hours.

Have you tried on another device?

Feel free to PM me more details, screenshots, and even a temporary API Key and I would be happy to look into it with you.

Edit: We did a bit more troubleshooting via PM and for some reason giraffe’s API key isn’t working with the APIs used in this tile. When I created a new API key, it wasn’t working for ~30 minutes, but then started working. If anyone else with a new Open Weather account experiences this even after waiting a few hours after creating the API key, I would be interested in hearing about it.