Tiles for TinyPro (Hikvision IP Camera) feeds?


#1

Is there a way to add a media tile that shows live streams from cameras set up in TinycamPro (or the native NVR for that matter)?


#2

Yes, the Media Tile supports any MJPG feeds which you can pull from TinyCam or many native NVRs.

Check out the following help article on setting up Media Tiles:


#3

For TinyCam, the following community post might be helpful: TinyCam with WyzeCam

In order to embed a camera feed from TinyCam into a SharpTools.io dashboard, you’ll enable the webserver that’s built into TinyCam and then you can access your camera feeds as an MJPG stream with the following URL format:

http://{tiny.cam.address:port}/axis-cgi/mjpg/video.cgi?camera={id}


#4

Thx, hmm, just seem to get a black tile when I try the above. Using Hikvision cameras, if it matters. Thinking about it though, TinycamPro is simply an app I use on my phone to view my cameras. They’re actually hooked up to a Hikvision NVR.


#5

Let’s see if I can figure it out with that spycamera link, the cameras are Hikvision DS-2CD2142FWD-IS. Internal Camera IP address and port is http://192.168.1.xx:65001.

No luck so far.


#6

For the TinyCam approach, you’ll need to make sure you first enable the webserver in TinyCam and that you can access it from a browser. Then modify the URL format provided above with the IP address of your phone/tablet which is running the TinyCam webserver.

Are you trying to connect directly to the camera or do you have an NVR as mentioned in your original post?

Looking through iSpyConnect, it looks like most of the URLs provided for that specific camera model are RTSP streams which won’t work directly with a web browser and thus won’t work in the SharpTools Media Tiles either.

From the iSpyConnect page, you’re looking for a ‘Type’ of either MJPG or JPEG and the ‘Protocol’ needs to be http.

From what I’ve seen on the ipcamtalk forums, it looks like there may be an MJPG option for some of the Hikvision series, but I’m not sure if it applies to your model or not:

First you have to set the sub stream to MJPEG while this is the only one available for MJPEG request (2xx2 IP cam series).

Then use the following syntax:

http://user:pass@ip_address/Streaming/channels/102/httppreview

As with the other solutions, I would try viewing this URL directly in your browser first to see if you can get an image to display directly in your browser. Once you’ve confirmed that you can view it directly in your browser, then try adding it as a Media item in SharpTools.

One thing I would note is that Chrome and some other modern browsers have started blocking the ability to have a user:pass@ip_address format embedded in pages (like SharpTools). If your camera supports disabling the username/password on your local network or has another approach for including the credentials, then you’re good to go.

If you can disable the username/password on the camera (at least for testing), then the format from the ipcamtalk forum post would be:
http://ip_address/Streaming/channels/102/httppreview

Alternatively, you might try the other formats which seem to be available on some Hikvision models:

  • http://[ip]:[port]/snapshot.cgi?user=[USERNAME]&pwd=[PASSWORD]
  • http://[ip]:[port]/cgi-bin/snapshot.cgi?chn=[CHANNEL]&u=[USERNAME]&p=[PASSWORD]
  • http://[ip]:[port]/cgi-bin/snapshot.cgi?loginuse=[USERNAME]&loginpas=[PASSWORD]
  • http://[ip]:[port]/api/mjpegvideo.cgi?InputNumber=1&StreamNumber=[CHANNEL]
  • http://[ip]:[port]/cgi-bin/viewer/video.jpg
  • http://[ip]:[port]/axis-cgi/mjpg/video.cgi
  • http://[ip]:[port]/image/jpeg.cgi

#7

Okay, can’t seem to access the Hik cameras directly or via the NVR. So trying the Tinycampro route. Not sure how one “enables” the webserver, the only clickable option is whether to use https or not. So I clicked the Use HTTPS box. Left user name and password blank. Port is 8083.

I then inserted:

“http://{tiny.cam.address:port}/axis-cgi/mjpg/video.cgi?camera=1”, with my tablet’s IP address in the “tiny.cam.address” section and the port as 8083 per Tinycampro.

Tried with both Https and http (enabling and disabling https check box". Both timed out in my browser.

Thanks for helping btw!


#8

ah…figured it out, there’s an enable webserver button that isn’t in the “settings” but in the main section of tinycampro…perfect!


#9

Yup! That’s it. Here’s a screenshot for anyone else who finds this thread while searching:

Edit: The HTTPS option can be left disabled as well. TinyCam generates it’s own SSL cert when that option is used which is invalid in most browsers anyway.