Mjpeg and iOS Browsers

Hopefully i’m missing something easy here. How do i get an mjpg stream to play in a browser on iOS? It works in Chrome on Windows 10, but not in Chrome or Safari on iOS 11.4.1.

What type of camera is it and what URL format are you using? I’ve used MJPEG feeds in my iPad, so I’m wondering if there’s something specific about the feed or URL format.

I just tried some streams from insecam.org and it worked on my iPad Air 2 with iOS 11.4.

For example:

For reference, I had to click through a few of the cameras from insecam to find an MJPEG stream rather than an image snapshot that refreshed.

I’ll update the iPad to 11.4.1 just to make sure something weird didn’t happen in that minor point release. :slight_smile:

Edit: The other thing you might check is that the MJPG source you are trying to reach is accessible from the iPad - eg. make sure it didn’t get switched to a guest network/different network somehow.

I’m trying a couple blue iris streams in format http://BI_IP:BI_PORT/mjpg/Cam_Short_Name/video.mjpg

Both the iPad and blue iris computer or on my LAN.

Thanks for the additional details. I just upgraded to 11.4.1 and tested against my Blue Iris instance and I am unable to reproduce.

I normally just use the format: http://{blue.iris.ip}:{port}/mjpg/{short_name}, but I tried your version with the trailing /video.mjpg and it worked too.

Do you have authentication required on your Blue Iris server? If I remember correctly, it’s in Blue Iris settings under Web Server → Advanced section → Authentication. I have mine set to something like "Non-LAN only" which means that I can hit the streams locally without providing any username/password, but if I try to hit it from outside my network, I have to provide the password.

Edit: Have you tried hitting the MJPG URL directly in your iPad browser (eg. outside of SharpTools.io)? If so, what are the results?

i’ll check that BI setting. Didn’t work directly in browser either, so not a Sharp Tools problem, a PEBCAK issue :slight_smile: Was just baffled why it would work on my laptop but not iPad with both on my LAN. Thanks!

1 Like