Show ring camera on dash

Hey guys, I’m using the kindle fire 8 hd with fully browser for my sharptools dashboard. Love sharptools guys. Anyway, I’m curious if I can get a camera tile for my ring doorbell that populated with the live footage from a ring motion event. I’m using SmartThings and have the ring doorbell added in there. I have downloaded the ring app from the play store as well. If I could get a 4x4 tile for ring that, when motion is detected, expanded to full screen with the video feed until the motion ends, then return back to dashboard. Or just show the motion in the 4x4 tile. Is any of this possible?

1 Like

Unfortunately, the SmartThings integration only exposes some of the attributes of the device (like motion), but not the video feed.

And since Ring doesn’t have an open API, there isn’t an official way of embedding the video stream directly into your dashboard. That being said, some people use an alternative approach with AutomateIt (or Tasker) to automatically bring up the Ring app when motion is detected.

From what I understand, it’s two rules that get setup in AutomateIt:

  • Rule 1: When Ring Notification is Received → Open the Ring App
  • Rule 2: When Ring Notification is Received → Open Fully Kiosk Browser, delayed by 1 minute

Another approach that we’ve seen used when you only want a doorbell stream to show up when the doorbell is pressed is documented in the following post:

It uses a doorbell sensor to detect the button press and uses that event to open the app.


Thanks Josh! I will give both of these a try and see what works best. Really appreciate the detailed answers!

1 Like

What settings would you have to have in Fully Kiosk browser to allow the Automateit app to open?

As long as the Kiosk Mode features which prevent other apps from opening are not enabled, AutomateIt should be able to launch other apps in the background.

@josh do you have a more detailed setup on AutomateIT for Fire HD 8 (10th gen). I am trying to set it up to open ring when the doorbell is pressed AND when motion occurs on the camera. And then have it close after 1 minute and go back to my dashboard.

@Denver, just to throw another option without having to use AutomateIT. You can also use Rule Engine and create a Fully Browser device using the Fully Kiosk Browser Device Handler to open the Ring app when the Ring button is pushed. I personally would suggest not to include the “AND motion is active” in the condition, but would be the rule example for what you described. (If you want the same behavior when the Ring button is pushed OR motion occurs, you can remove the IF_Condition, and add the Ring motion status changes to “active” in the Trigger section.)

EDIT: update the rule example to trigger the rule when either Ring button is pushed or motion is active, and update the command to bring Fully browser to front 1 minute after.

1 Like

James - in your example, are you waiting 60 seconds before displaying the camera?

I’d like to do it the way you show it but am having issues with this part and the link. " Fully Browser device using the Fully Kiosk Browser Device Handler" do you have a simple step by step guide for what I am trying to do and I like your idea about the OR function in lieu of AND? I have no clue how to download that DTH like you talk about in the other link. I was although able to create the device handler in smartthings for fully kiosk. Also when I add it to smarthings devices it works but when I go to manage devices and add it in fully kiosk and sharptools dashboard I get this " Oops! Uh oh! We couldn’t complete the authorization. Try again."

I think SmartThings is having server issues at the moment. I was able to reproduce and I also tried authorizing SmartThings to IFTTT and Logitech Harmony it’s not working on those either.

The delay is after opening Ring app as the @Denver’s request is to show the Ring app for 1 minute and then close it ( return to the dashboard).


Did you create the device handler by copy & paste the device handler code referenced in the other link?

Here are the detailed steps:

  1. In Fully Kiosk Browser, go to Settings → Remote Administration → enable Remote Administration, and set password.
  2. Exit Fully Kiosk Browser from tapping “Exit Fully” in the left menu and open it again.
  3. Grant the permission on your device need by Fully ( there should be 4,5 permission needed for this Remote Admin to work)
  4. Go to SmartThings IDE (
  5. Me Device Handlers → Create New Device Handler → From Code and paste the DTH code referenced in the link
  6. My Device → New Device → Create the device for your Fully Kiosk Browser and select the device handler created from step 2
  7. In SmartThings new app, find this newly created device, tap the vertical “…” at top-right corner and “Settings” to configure the IP of your tablet, password for using Fully Remote API from Step1.

Please note that I updated the rule example I post earlier. Realized the command loadStartURL doesn’t bring the Fully app to front, and have to specifically use bringFullytoFront command, and I changed the trigger logic as I suggested.

1 Like


I feel like I’m 1 little issue from getting this working. I’ve deleted and reset this up in Smartthings like 13 times tonight. I’ve got the Device Handler in and the new device is setup. I’ve entered my IP, Port (the default) and Password. I’ve even tested this to get the Ring app to launch in my Chrome browser controlling it remotely works, but the Smartthings integration breaks it and isn’t passing the info. I’ve tested the rule by automating an email in the rule and that works so I know that the rule works as I added it to the dashboard as a tile. I tried to make it exactly as your example above where it would trigger the Ring app to launch on Motion or Button Press but just one little thing isn’t working. I’ve also made sure the Fire10 Tablet has a Fixed IP address and the port is open on the router.

Any ideas?

Here’s what the log spits out:
a449e88d-b0c4-4768-8bad-9b9884ffdf58 2:22:18 AM: error java.lang.NumberFormatException: For input string: “Http://192@line -1 (doCall)

a449e88d-b0c4-4768-8bad-9b9884ffdf58 2:22:18 AM: trace [STsendCommandPost] cmdDetails:cmd=loadURL&url=intent:#Intent;launchFlags=0x10000000;;end to Http://

a449e88d-b0c4-4768-8bad-9b9884ffdf58 2:22:18 AM: trace [loadURL] ST url:intent:#Intent;launchFlags=0x10000000;;end

a449e88d-b0c4-4768-8bad-9b9884ffdf58 2:22:18 AM: trace [loadURL] entered

86ea8ba7-723f-4e94-beec-6d4ca169f362 2:22:17 AM: debug updateDevice, params: [appId:86ea8ba7-723f-4e94-beec-6d4ca169f362, param1:devices, param2:a449e88d-b0c4-4768-8bad-9b9884ffdf58, action:[GET:executeSmartAppGet, POST:executeSmartAppPost, PUT:executeSmartAppPut, DELETE:executeSmartAppDelete, OPTIONS:executeSmartAppOptions], controller:smartAppApi, id:a449e88d-b0c4-4768-8bad-9b9884ffdf58], request: [arguments:[intent:#Intent;launchFlags=0x10000000;;end], command:loadURL]

Can you clarify what it is that you tested that works?

Looking at the logs, it seems like something fundamental with the Fully Kiosk Browser (FKB) Controller device handler is failing. Have you verified that you can use the ‘device’ that’s created in SmartThings and it works? My first suspicion would be to double check the configuration of the FKB device in SmartThings.

Josh yeah I’ll clarify. I meant I can type the IP and port of the tablet in Chrome and can access the Remote functions of FKB. So I can launch the Ring app from the browser so I know the remote capabilities are working.

Yeah, something is not working with the smartthings device. I’ve added a ton of custom device handlers over the last 5 years and not had issues so I must be missing a step. I’ve gotten no data to come across the device as seen in the history. That’s been the case each time of the dozens of times I’ve tried to delete and re-add.

I haven’t used the FKB DTH on SmartThings in a while, but is the Server IP Address field supposed to be only the IP address? eg. drop the http://

In other words, just the numeric IP address:

Just checked my settings, and the ip address field should be the ip only as @josh mentioned.

1 Like


Thanks! I swore I did tried that last night as I took that off in trying to figure what was wrong. Tried changing to NO http, tried different ports etc. Thanks! Definitely works now.

The help from the two of you on here is awesome! I’ve been lurking and plodding away since last summer and all the comments and help you guys give is awesome! Much appreciated as Smart Home Life is very much a trial by fire lifestyle for the last 10 years so it’s nice to have people to ask questions and bounce ideas past.