Tiles moving when saving

when i have added and arranged some new tiles, then when hitting save the tiles randomly rearrange, any way to avoid that?

Hi @Claus_Hansen sorry to hear that the layout changed when saving the dashboard. A few questions:

  1. What browser are you using? and if it is a PC/Mac or a tablet/mobile device?
  2. Can you reproduce it in another browser?
  3. If you have access to a PC/Mac, does the issue still occur after slightly change the browser window’s size?

I would also be a good idea to take a short video and let us know the dashboard id (in the dashboard url), so we can investigate the root cause. Thanks.

I’m also encountering this. I had experienced it early in my adoption of ST but it seemed to have been resolved; just recently returning.

I’m using Chrome on Win10 and I make changes in DevTools mode.

My gut says it’s somehow related to the tile arrangement logic when tiles of various dimensions are used in the same Dashboard. It seems to have gotten worse after I recently added a couple 4x4 tiles to my layout. It now includes 1x1, 1x2, 2x2, 4x4 tiles, and Super Tiles. I haven’t been able to determine a pattern, but it’s usually after adding something new to the dashboard. Even adding a simple spacer tile can cause rearrangement havoc when Saving. I’ve started making backup Dashboards before making any changes.

@Eric_Dunn & @Claus_Hansen, can you please verify if this tile moving issue can still be reproduced in the beta site? (And refresh the page before your test.) I’ve deployed an update to the beta site and would like to see if that helps eliminated the problem. Thanks.

i have now tried doing the same changes in the main site and in the beta site, and the issue with tiles moving out of places only occurs in the main site

1 Like

@James, I played around with adding, deleting, resizing, and moving tiles in the Beta for about 15 minutes and can’t reproduce the problem. Looks like you found it. Great job!

1 Like

@Eric_Dunn & @Claus_Hansen, thanks for the promptly tests. I’ve just rolled the fix to the main site, and you may need to refresh the page to load the fix. :sunglasses:

1 Like

@James Unfortunately, this issue still lives. It happened twice so far this morning on the Beta. Let me know if more info is needed.

@Eric_Dunn, can you send the dashboard’s id (the URL of the dashboard) to support@sharptools.io along with the steps how to reproduce this issue? Thanks.

I had this happen today as well. I added a tile on the tablet, everything looked good, saved it and it went all haywire. Used the PC to put everything as it was (tiresome on the tablet), saved it, reloaded on the tablet and all was fine.

Just now had it happening again. I added a tile on the PC, went to the tablet to check if it worked and looked okay. Everything was put into different places again. Reloaded the dash and everything was okay again.

Having same issue… Tiles in the row I edit are slipping into different positions when saving. Need to edit again re-position and resave to correct it

@kampto, can you provide more details how you can consistently reproduce this issue and it would also be greatly helpful if you can take a video of the process. Can the issue be limited to a specific browser, device, certain dashboard, and etc? Thanks.

What’s best way to take video? Happens in Chrome and MS Edge. Its repeatable.

1 Like

OK, I figured out how to capture video in Win10. How to get you this large file?

For larger files, most people use Google Drive, OneDrive, iCloud, or YouTube. For files under 10 MB, most email clients will allow you to email them to support@sharptools.io

Youtube link. This happens in Chrome and Edge. Sometimes its more then one tile that moves during save. Doesn’t look like a big deal but it takes like 20moves to get it all back in the right spot and resave.

Thanks for sharing. So every time that particular tile is edited and then saved it causes it to get moved?

Yes, every single time. And same goes with the other tiles in that row, they shift when saved.

1 Like

@kampto I had this problem when using Chrome. In my case, I discovered that it only happened when I edited in the standard browser display. I have had no issues as long as the edit/save is done inside Chrome Developer Tools. Hope this helps.

@James Sorry, this fell off my radar. It only happens when editing outside of Chrome DevTools.