Thermostat Stopped Working

I using a Hubitat hub connected to a T6 Zwave Honeywell thermostat. This has been working perfect for some time and now I can’t get the temp to go up/down with the arrows via sharptools. The device works fine from the Hubitat menu letting me turn up/down the temp. I can click on settings and make other adjustments via sharp tools. I can even adjust the temp up and down in the settings option. I just can’t adjust the temp up/down from the main display. Any ideas?

Wanted to add that the double stack Sharptools option does seem to work ok. I never noticed that was available, but I still prefer to use the standard thermostat options and that is not working when I turn the temp up/down.

Hi @Chadman - if the thermostat is in “Auto” or a similar mode, then the temperature adjustment controls are disabled when the Single Height thermostat layout is used as the tile wouldn’t know if you want to adjust the heating setpoint or cooling setpoint.

When using the ‘auto’ mode on the thermostat, we would generally recommend using the Double Height thermostat layout as it exposes individual controls for the heating and cooling setpoints directly.

I’m seeing this even if I have selected Heat or Cool. For the last few months since I have been using this, I have used it for heat using the single line display. This has always worked and a few weeks ago I noticed it stopped. I have tried to use auto, heat, cool, all with the same results. The 2 bar display does work, but the other should also work with how I’m using this since I never use auto anyway.


Can you share the Doc ID for the device via support so we can take a closer look? It might help to include screenshot(s) of what you are seeing in the Thermostat UIs too. :slight_smile:

I have the same thermostat, but the double stack is not available to me.

@Josh I think we talked about this before. The Honeywell seems to report the ability for set cooling, but the actual device has no such functionality. It always uses set heating, regardless of its mode. If I remember correctly…

I emailed you the doc id. Not sure if that is safe to show on this page or not.

This id is for a thermostat I use upstairs. So for a test, I created a single stack and double stack thermostat object with Sharptools. I can adjust the AC with the double stack using the AC option. When I do this, I can see changes in the single-stack version of the upstairs thermostat. If I make the changes to the single-line thermostat, they do not register on the double stack or on the thermostat itself. I have the single stack setup for AC so it should know what setpoint to adjust. I can confirm this worked with heat and ac in the past and not sure why it’s not working now. Below is a screenshot of my phone display. You can see that both upstairs turned blue when the AC kicked on. After that I move the single stack up a few degrees, but it did not change the temp of the double stack. If I adjust the temp on the double stack, I do see it change on the single stack to match up.

1 Like

Just an update for anyone following the thread that we were able to identify the issue based on the information @Chadman shared and we pushed a tweak to the Thermostat tile that resolves the issue.

The issue was that this particular thermostat device driver reported a custom capability “Thermostat Setpoint” which is used by one of our new platform integrations, so it was conflicting with that. We made some tweaks to the Thermostat Tile to better accommodate this and Chad confirmed it resolved the issue. :smiley:

Thanks again for reporting and for sharing the device details!


Thanks so much for the fast fix!

1 Like

2 posts were split to a new topic: HASS Honeywell Thermostat Setpoint Issue