HASS Honeywell Thermostat Setpoint Issue

I am still unable to change the setpoint from the double-stack tile. I’m using the Home Assistant integration for Honeywell TCC.

I recollect that I could change the setpoint using the user-developed Hubitat driver, but the drawback of that driver is the status of the heat pump doesn’t change on the dashboard during the lengthy poling interval. Many times the heat pump runs for a shorter time than this interval, so you never see the correct status on the tile.

The Home Assistant integration changes the tile state within a second or two.

I suspect something changed with the Honeywell integration (or general climate entity) as I believe I’m seeing the same thing with my test HASS instance.

In fact, my Honeywell integration was offline and when I was sending the commands they were getting interpreted correctly. But when I restarted the Honeywell integration to reconnect my thermostats, I noticed that the correct command was being sent across, but it was effectively being ignored for some reason:

2023-06-12 13:10:24 debug: Received command. {"entityId":"climate.upper_level","type":"call_service","data":{"domain":"climate","service":"set_temperature","serviceData":{"target_temp_low":67}}}
2023-06-12 13:10:24 debug: Converting service command for domain climate and service set_temperature
2023-06-12 13:10:24 debug: Send get_states request to HA.
2023-06-12 13:10:24 debug: Call HA service - {"id":22,"type":"call_service","domain":"climate","service":"set_temperature","target":{"entity_id":"climate.upper_level"},"service_data":{"target_temp_low":68,"target_temp_high":73}}.

You can see that in the first line, I lowered the ‘heat’ to 67, but in the last line it still uses the existing heating setpoint of 68 for some reason. :thinking:

1 Like

I’ve identified the issue and implemented a fix… the build system is compiling new images for Home Assistant now. I’ll post another update when the update is available. :slight_smile:

1 Like


SharpTools Home Assistant Addon 1.0.8 has been released which should resolve the issue with the heating setpoint not properly getting set. Make sure to update your addon and then try again! :smiley:

Thanks again for reporting it!

Thanks so much for the quick fix! Makes me wonder why I didn’t report it earlier.

However - it’s still not working for me. I updated the addon to 1.0.8. Is there anything else that needs to be done?

Can you share more details about what you’re trying and what’s happening?

It might help to see a snippet of the add on logs from when you control the device similar to the snippet I showed above alongside a description of the action that you tried to take.

Edit: I’m away from my computer, but I’ll double check the builds later and make sure they all updated as expected too. I just tried from my phone and I think I’m still seeing the same issue. I could have sworn I tested the release earlier, but perhaps I tested the wrong thing. :grimacing:

I’m stuck trying to find the configuration page in order to turn-on LOG_TO_FILE!

In addition to updating the add-on, I had restarted Home Assistant.

I double checked and the update built as expected and I tested properly. :sweat_smile:

That being said, it still wasn’t working for me, but it was my Home Assistant’s Honeywell “Total Connect Comfort” integration that was failing again.

When I was trying to diagnose what was wrong, I checked Home Assistant → Developer Tools → States and I noticed that my thermostat was showing offline again… which explains why the command was going through from SharpTools, but not taking any effect on the thermostat itself.


Once I reset the integration, the commands started working as expected for me.

Add On Logs

As for how you can get Home Assistant logs, they are available without any configuration. You can go to Settings → Add Ons → {Your Addon} (eg. SharpTools); then tap the Log tab at the top. The Log tab might only be available on larger screens (eg. not on a phone).

My thermostat is not offline - although that’s a frequent (maybe once or twice a month) occurrence, requiring resubmitting the password to fix. But I’m online now, so nothing to fix.

My quest for logs was in response to your asking for a snippet of the add-on logs. In the add-on, Diagnostic Data > Advanced shows this error message if you attempt to export the logs.

You might see why this old geezer is confused…

That’s a related, but different feature. The Add-on is always logging what it’s doing by writing to the Home Assistant log streams which are only accessible within the Home Assistant UI. The feature you mentioned is a separate feature that writes the logs to a file (more on that below).

If you check the last screenshot in my post above, it’s a screenshot of the Home Assistant management interface for the addon and the tabs at the top let you change to the Configuration and Log screens.

Here’s a video showing the process…

The Configuration tab shown in the screenshot (and my video above) is where you would enable LOG_TO_FILE if you wanted to. What that feature does is enable the Addon to write the logs to a file rather than just writing to Home Assistant’s log stream. By writing it to a file, the Addon then has access to export that file so you could download it to your computer - for example if SharpTools support asked you to send the whole log file.

The reason LOG_TO_FILE is not enabled by default is it significantly increases the amount of disk writes. For a full-fledged computer running Home Assistant, this isn’t a major concern… but many people still run Home Assistant on devices like Raspberry Pis where their storage device is an SD card that has a limited number of writes. So if the addon was constantly writing to the SD card, it could wear the SD card out and cause bigger issues.

In this case, I was just looking for the snippet that you should be able to see when using the Log tab shown in my screenshot and video demos above.

Thanks Josh. I’m not ignoring you! I won’t be able to get to this for a day or two.

1 Like