Tasker Integration Not Working?

If I open my garage door or door lock with SharpTools, it works fine. However, no matter what I try, it will not work when sending the command thru Tasker. I’ve whittled my task down to nothing but the SharpTools command to open the garage door and nothing happens when I run the task. I’ve seen some posts on the Tasker Google group about problems with plugins issuing commands thru tasker. Is there something I can do about this? Suggestions?

Test Open (121)
A1: A Thing [ Configuration:Thing: Kitchen Door
Command: lock Timeout (Seconds):0 ]
A2: A Thing [ Configuration:Thing: Garage Door 1 Car
Command: on Timeout (Seconds):0 ]


What make/model device is your phone/tablet and what Android OS version are you running? I’ve seen spotted reports of this in the past few months, but haven’t been able to reproduce it myself yet.

Sorry, meant to include that. It’s a rooted Nexus 6P running Android 7.1.2. Of course, it worked fine when I arrived home a few minutes ago. So it does seem to be an intermittent problem. Sometimes it works and sometimes it doesn’t. I don’t know what the circumstances are that cause it to happen and to not happen.

1 Like

Thanks for the additional details. If you notice any other circumstances about the patterns, I’d love to know so I could try to reproduce it.

I’m suspicious that it could be something happening when the main SharpTools app hasn’t been opened in a while as I recall another user having that problem with their device. They worked around it by having a recurring Task which occasionally launched the main SharpTools app and then put it in the background. I don’t recall how often they had this run, but you could give it a try on maybe a daily schedule and see if the problem persists.

I just sent my Nexus 6P back to Google a few weeks ago, so unfortunately I don’t have that device to test with anymore, but I’ll see if I can setup a test device and only use Tasker (without opening the main app) and see if I can reproduce it.

Also, do you reboot your phone ever? I don’t think it would play into this, but since we are riding blind here I’m just trying to collect any data we can!

I’ll try setting up an app to run SharpTools to see if that helps but when I was testing I was working in SharpTools and then switching to Tasker so not sure how opening the app would help but I’ll try it. Also, my phone reboots every night (using Tasker and another plugin). Thanks.

That’s good info. I agree that automating the opening SharpTools wouldn’t help in that case.

Can you run through some sample Tasker tasks and pull logs from Tasker and SharpTools? For Tasker, you’ll need to enable the logs before running the test. For SharpTools, you’ll need to send the logs relatively soon after running the tests (eg. if you send the logs the next day, they might have been overwritten by then).

For test purposes, you might pick a single device for the test and then run the following steps - a light switch makes a good test:


  1. Start with the light physically turned off
  2. Ensure Tasker logging is enabled
  3. Create a Task for turning the light on
  4. Create a Task for turning the light off
  5. Create a SharpTools widget for turning the light on
  6. Create a SharpTools widget for turning the light off

(PM me if you don’t have the widgets IAP unlocked and I can take care of it for you)

Testing Steps:

  1. Open the main SharpTools app, find your thing in the list, and turn it on
  2. Wait 5 seconds and turn the light back off
  3. Open Tasker and run the task to turn the light on
  4. Wait 5 seconds and run the task to turn the light back off
  5. Run the widget to turn the light on
  6. Run the widget to turn the light off
  7. Send the SharpTools Logs: Support > Send Logs
  8. Send the Tasker logs

I will try this evening. I didn’t have widgets enabled but I just purchased the option. More than happy to help the cause. Will let you know later.

1 Like

I created tasks and widgets. All four worked just fine (although the widgets were a little delayed in updating that the lights were on or off). I sent you the logs by email.

By the way, I did set up a profile/task that runs SharpTools now and then. When I’m at the office during the week, I display my calendar on my phone (because the office blocks google calendar). So I added a line to the task to run SharpTools and then display the calendar. I don’t know if this is a factor or not.

Also, and obviously, I ran SharpTools to test the widgets and tasks, so it had been activated before sending the logs. Maybe if my garage door routine fails I’ll send all logs again (although it worked the last two times I drove home – go figure :slight_smile:).


Thanks! I received the logs and will look through them, but if everything was working then it probably won’t have many clues.

Thanks again and sorry that you’re experiencing the intermittent issues. (If it happens again, I’d love to take a look at the logs!)

I’ll send logs next time it doesn’t work.

1 Like

My garage door open task just failed so I sent you Tasker and SharpTools logs by email.

Thanks. I requested access to the file that was linked in the email. I assume it has both Tasker and SharpTools logs in it?

This is exactly problem I’ve been having and have been in contract with you through email. I thought it was fixed after hard resetting my phone, but it is still intermittent. Tasker just hangs occasionally when using your plugin. Always ends in a timeout. Only thing I saw weird looking through the logs from your app were “location DB match failed. Falling back to using the first location in the DB”

1 Like

Any progress on this? It is getting immensely frustrating. Tell me what I need to do, to give you more info.

I’ve received a couple of log files and I’m trying to track down what’s happening. I still can’t reproduce it on any of my devices. Nothing has changed from the SharpTools side of things, so my suspicion is it’s something blocking or delaying the handoffs with Tasker and SharpTools.

You mentioned that you are on a Pixel 2 XL with the latest software patches (which I am too)… have you tried whitelisting SharpTools and Tasker in any battery management (and VPN, Task Killer) features?

For example, on a vanilla Android install:

  1. Go to Android Settings
  2. Select Battery
  3. Tap the ... overflow and select Battery optimization
  4. Make sure “All Apps” is selected from the drop-down
  5. Find SharpTools, tap it, then select “Don’t optimize”
  6. Find Tasker, tap it, then select “Don’t optimize”

Note: For anyone else sending logs, please be sure to send both Tasker and SharpTools logs both from the same time as the failed event so I can see what’s happening on both sides.

Yes, I have done this already.

Is this a symptom, our something you’re working on? Wasn’t getting this before yesterday.

Emailed more logs to you too.

This is a symptom, but nothing has changed in SharpTools since you posted the issue. This means that Tasker is sending over a non-ordered broadcast.

Unless the developer docs have changed, Tasker should only send ordered broadcasts and plugins should filter out non-ordered broadcasts.

Started working perfectly a few days ago. Nothing changed, just boom, back to working. I did talk to the Tasker developer though, he said non-ordered broadcasts are sent if the command timeout is set to zero. I was trying all different things, so the log I sent you, the timeout was set to zero for that particular fault.

1 Like