SmartThings Authorization Unknown Error


Today I did something similar in that I changed the names of 2 devices. When I went to reauthorize Sharptools using my phone, I got the following error message when I selected Samsung SmartThings:

Usually when I haven’t done this in a long time, it asks me to log in to Samsung, but the log in screen did not present itself. I could re-authorize from both my desktop and my laptop (note I am using Chrome in all cases). Any ideas why I can’t re-authorize the Sharptools connection to SmartThings on my phone?

Try using Incognito mode in your browser to login and authorize the location.

I’ve seen two other reports of this recently and using Incognito mode has solved it in both cases. I suspect that SmartThings might have tweaked something with their authorization servers that’s causing this issue for some people.

If it works in incognito mode, you could try clearing the cache in your browser.

Incognito mode worked. But I’m having a hard time clearing out regular mode. I don’t want to eliminate all cookies etc. as that will mess up other stuff saved on other sites. Am I looking for Samsung or Sharptools cookies and history?

SmartThings / Samsung

So domains like:


Tried to remove all those. Then I did the clear cache in the Chrome settings. Then tried to clear data. Then uninstalled all Chrome updates (doesn’t look like I can uninstall Chrome completely) and reloaded the latest version. All no good. Still get that error message.

So I give up. I’ll either have to do it in incognito mode if I do it on my phone, or else from my windows laptop, or desktop, or even iPad, which all seem to work. I will check every once in a while to see if that function magically reappears in Chrome on my phone.


Just to confirm, you mean you cleared the cache inside the Chrome app UI? Tap the ⠇menu in the top-right → Clear Browsing Data?

I suspect it’s just the “Cookies and Site Data” as I’ve seen the SmartThings login form act funky before and that’s fixed it for me, but since I’m not experiencing the issue I can’t speak to it.

Keep in mind that Chrome does some fancy cloud syncing with cookies and browsing history… so even if you clear the Cache/Data from the App Information section on your phone, Chrome will automatically sync stuff back down from the cloud when you reopen it.

The error is being returned from the SmartThings authorization servers so you could reach out to their support, but I suspect they will suggest clearing all Chrome browsing data as one of the initial troubleshooting steps.

Well, I did that first. I even told it to go back to “All time”. So now all other web bookmarks on my phone will have to have ID’s etc. re-entered. A pain, but I can deal with that. But what I meant was I even went into Settings->Apps->Chrome->Storage->Clear Cache.

I know my bookmarks are still synched, because they all came back after I updated Chrome. But I’m not sure about cookies etc. because, for example, on my phone now the bookmark for a banking website no longer has my ID # in the drop down, yet my iPad and desktop Chrome browsers still have it.

@josh , I just posted in the ST community to see if anyone else is experiencing this.

Hi @Allan_P

I haven’t experienced this on three Android devices (two Samsung Galaxy Note 10+; one Samsung Tab 8) (in both Chrome & FireFox)

Note 10+ are running Android v12

All three are running Chrome v122.0.6261.120

What Phone & OS version are you running?

Have you tried FireFox as well?

Samsung Galaxy S23 FE
Android 14, One UI version 6.0
Chrome v122.0.6261.120

Never had this problem with my previous Galaxy S20 FE

I have tested this with both the built in Samsung browser and MS Edge. They work fine, they let me connect to Samsung to synch.


I factory reset the phone. I did the minimum to get past all the initial Samsung sign on accept policies etc. Then I went into Chrome. After signing in to Sharptools, I tried the Manage Connections. It worked fine. It let me connect to SmartThings.

Now I’m reloading my phone from my SmartSwitch backup. I couldn’t find any way to not select to restore Chrome. So now let’s see what the restore process destroys.

From your screenshot over in the SmartThings thread, it looks like the authorization flow is redirecting you to the SmartThings app rather than letting that all happen within the browser. That’s something I’ve never seen before if that’s the case. :thinking:

When I tested it after the factory reset and it worked, it must have been loading it within the browser as I don’t have the app on the phone yet. I am waiting for my phone to reload, and will try again.

1 Like

See update here SmartThings Authorization "Unknown Error" - #13 by allanp - Devices & Integrations - SmartThings Community