[RESOLVED] Open Weather Custom Tile Has Stopped Working

I’ve been using open weather custom tile without any problems and today for some reason has stopped working, any help I would be very grateful

1 Like

Can you reopen the dashboard and check again? It looks like it’s working now, but I’m guessing that one of the external dependencies wasn’t loading earlier when you tried. Unfortunately, I only had my mobile phone on me at that time, so I wasn’t able to look at the browser console logs to see what wasn’t loading.

On a related note, I pushed an update last night that improves support for the ‘2.5 multi’ API and adds an option to pull in the Air Quality (I was just waiting for someone who requested it to test it before announcing). You can update your tile if either of those features are important to you. :slight_smile:

Looks like it’s happening again. I suspect that unpkg, which is hosts some of the external resources, is having issues…


The weather tile has been on and off for me this morning as well. It’s back off at the moment.

For what it may be worth, I’m not seeing any errors in my direct API calls from Hubitat. :man_shrugging:t2:

Thanks for sharing. The Weather API itself is fine. There’s two other dependencies (shown in the screenshot above), which are used for fetching and displaying the data in the Custom Tile and the site that hosts those appears to be having issues.

Edit: It looks like it’s a widespread issue for unpkg with a large number of +1’s on an issue created in their tracker recently.

1 Like

I just pushed an update that switches the dependences in the Open Weather Custom Tile from Unpkg to another popular CDN, JSDelivr. You can use the steps noted in the post above to pull in the updates.

1 Like

Hi, No still not working, but I seem to have gained a red header for some reason

Thanks for the update. Please refer to the rest of the discussion above. The site that hosts some of the external dependencies for fetching and displaying the dependencies is having intermittent issues.

I just pushed a update a few moments before your reply that switches from the ‘broken’ host to a new one if you want to update the custom tile and try again.

I deleted and re-added to my dashboard, all working again now, thanks

1 Like

Just to be clear that the Unpkg host still seems to be having intermittent issues.

The last update I made (which happened moments before your reply and potentially after you had done your first update) switches to a different host for those resources. If you haven’t already updated again, I would do that to make sure it’s switched over to the new host for the external resources.

All done, since the update its started raining outside, you haven’t messed with the weather aswell :rofl:

1 Like

It’s raining here too! But at least we get to enjoy those beautiful rain animations. :stuck_out_tongue_winking_eye:

1 Like