[RESOLVED] Hubitat Authorization Outage 2021-02-20


All my Dashboards I have spent hours creating have all wiped.

Sharptools is claiming :-

But Sharptools has access to EVERYTHING - almost.

How do I get these dashboards restored back before Sharptools deleted everything?

All the displays around the house are now showing empty.

Thanks for posting and sorry to hear that things aren’t working as expected. Are the dashboards actually showing completely empty or all of the Thing tiles are showing Placeholders? A screenshot might be helpful.

The first step I would take is to reboot the Hubitat hub, wait several minutes for things to calm back down, then we authorize things starting from your SharpTools.io user page.

As a troubleshooting step, I would try authorizing only the devices you are actively using on dashboards. First that doesn’t help, try deauthorizing everything, then authorize just a small batch of devices. It’s possible you have a device or devices which are causing the hub to bog down or the Hubitat cloud relay to fail during the device synchronization process.

All the Dashboards are like this

The only things left are Text - Calendar - external items

Every dashboard has been completely stripped of content

I am hoping you have a backup you can restore - not going to spend all that time again, just to have it trashed again.

Rebooting the HE Hub now


HE Hub is rebooted.

I have reduced number of items synced to ST.

All the ‘Things’ from HE Hub have been deleted from all 10 Dashboards

I checked Connections and ST has lost connection to HE Hub.

Attempted to reconnect and ST claims that HE Hub is offline - which it is not.


A: How do I get Sharptools to connect to the HE Hub?
B: Where/how do I restore all the Dashboards?

I can’t connect SharpTools to either of my Hubitat Hubs this morning. Both hubs are working - SharpTools just says ,“Oops - something went wrong”

Yup just checked it against my other HE Hub.

According to SharpTools every Hubitat has suddenly gone offline.

I wonder where the problem could be?

I have removed every device from HE Sharptools app.

ST still cannot connect to the HE Hub.

I will go an try and replicate the Dashboards in HE - they will look like shit but be 100x better than Sharprtools with no data in them.

That message comes directly from Hubitat’s Authorization service and indicates that they cannot communicate with your hub.

I just tried on a few hubs as well and It is not working for me either. It seems that the Authorization Services (or part of the cloud relay?) is having some sort of outage.


If SmartTools loses connection with the HE HUB are ALL the HE Devices deleted from the Dashboards?

Are All the Dashboards now Dead for all HE users?


I am using the Hubitat App using mobile data and wifi off - and I am able to access the HE Hubs through the Dashboards but reports that 'Safari cannot open the page because your iPhone is not connected to the internet."

Interesting because Safari is work just great using my 4G connection - interesting that Hubitat is reporting the iPhone is having issues.

Anything that uses the Hubitat authorization services / cloud relay is going to be impacted. I just tried reauthorizing Google Assistant, Alexa, and IFTTT and they are all experiencing the same issues.



If SmartTools loses connection with the HE HUB are ALL the HE Devices deleted from the Dashboards?

Are All the Dashboards now Dead for all HE users?

1 Like

Hello, from one moment to another I lost the connection between my Hubitat c7 and sharptools (Running on a tablet). I rebooted the HE and it still doesn’t work. I get the following message: "Oops!
Hub is not responding, please verify it is running and connected to the Internet. "What I have not tried yet is to restart my Router.

@Ignacio_Fotografias Not a local issue.

Looks like an outage with Hubitat Cloud :frowning:

Just tried connecting IFTTT to HE and it is failing too.


If SmartTools loses connection with the HE HUB are ALL the HE Devices deleted from the Dashboards?

Are All the Dashboards now Dead for all HE users?

Hi @Ignacio_Fotografias - welcome to the community and thanks for posting. I’ve merged your post in with an existing thread about the same topic.

Hubitat’s Authorization services seem to be experiencing some sort of outage at the moment as services like SharpTools, Google Assistant, Alexa, IFTTT, etc are unable to authorize devices from Hubitat at the moment.

No. In your case, a device sync likely ran during the Hubitat outage… when SharpTools asked Hubitat for the list of devices you currently had authorized, it responded with no devices.

All of my Hubitat devices are still connected and I can still control them, but I cannot authorize any new devices.

Ok thanks - so the Dashboards that are showing with ALL devices removed will be restored when ST is able to re-connect to HE.

Because I will need to identify from the Dashboards all the devices each Dashboard uses so I can add it back into the Sharptools sync in HE that I was asked to remove earlier.

That is a massive relief to not have to recreate all those dashboards again.

Yes. Avoid editing the dashboards or removing tiles from dashboards.

The ‘Placeholder’ tiles are placeholders for devices that are no longer authorized to SharpTools. Usually this occurs when you explicitly deauthorize a device… when you reauthorize the device, it rehydrates that device in whatever dashboards or rules it was used in.

In this case, it looks like the timing of a device sync for you lined up with whatever’s going on with the Authorization systems / Hubitat Cloud Relay at the moment. :frowning:

As long as the placeholders are there (eg. don’t edit the dashboards), they will get rehydrated when you are able to get them synced over again.

Just an update that I’ve edited the topic title (and some of my replies) to clarify that this doesn’t seem to be a complete outage of the Hubitat Cloud Relay (which is used to communicate with and send commands to your hub), but seems to be primarily impacting Hubitat Authorization services.

If you already had devices authorized and they are displayed on your dashboard, it seems that you can still control them.

It looks like your case is a bit unique in that something happened to lose the devices (eg. device sync / auth issue) and since the Hubitat authorization services are down you can’t reauthorize them to bring them back.

1 Like

I have no placeholder tiles just blanks were all the Hubitat devices were.

Had to enter edit mode to capture the screenshots requested.

As long as you have them backed up not an issue, just a matter of accessing the backups and working out what devices need to be shared on the HE in the Sharptools app.

Then all 10 dashboards should be restored.

I would have to take a closer look to see what’s going on - I can take a closer look at Placeholder tiles when I’m back in the office next week. It looks like you’ve got a customized Theme, so I’m wondering if the “Placeholder” text is staying “black” and since the background is black it’s just not visible.

The dashboards still have a reference to the Thing… it’s just that SharpTools doesn’t have access to the thing anymore so it’s not displayed. It’s not a “backup” so much as the reference to the Thing just needs to get restored.

As mentioned above, avoid editing your dashboards. Once the Hubitat Authorization services come back online, reauthorizing the devices should get them rehydrated.

@Michael_Horton, @Stan_Silverman, and @Ignacio_Fotografias have you reported the issue with being able to authorize devices to Hubitat support? Just want to make sure they’ve gotten reports of this as well so they are aware of the issue.

1 Like