[Resolved] Editing Dashboard on iPad has challenges

You may already know this and it’s a conscious compromise. If so you can ignore it.

When trying to add a new thing I am unable to scroll to those items lower on the list.

When trying to edit a tile, the edit dialog will appear at the top of the screen meaning I have to scroll up to get to it. Not usually a big deal but in Edit mode if I touch any of the tiles it will grab the tile and attempt to move it vs scroll the screen. You have to try and touch the screen between the tiles in order to scroll the screen, quite a small target.
I would think that while the Edit dialog is up that tiles could be frozen until the edit dialog is closed.

I don’t do any major editing on the iPad but occasionally I might wish to add a new tile or edit an existing tile. Until re-organising tiles becomes easier I would not attempt it on an iPad.

P.S. I’m using Chrome on my desktop and iPad for syncing of bookmarks.

1 Like

Thanks for sharing. What iPad model is this and what version of iOS is it running?

iPad Mini: Model MK9Q2LL/A/
IOS: Don’t see the OS version but its offering to update me to 12.3.1. Definitely 12.X
Chrome version: 75.03770.103

1 Like

Similar issues on iPhone X using chrome.

1 Like

Are you able to scroll the Add Item list?

I was able to reproduce the issue where the Tile Editor appears at the top of the screen (it’s supposed to show up roughly at your scroll position), but I couldn’t reproduce any issues with scrolling the Add Item list.


Edit: I touch and drag starting on one of the floating action buttons in the bottom right to scroll up and down without moving the tiles.

Josh, I’ll upload a video tomorrow.

Thanks, Gary. I meant to target the reply to @kevin to see if he also experienced issues scrolling the Add Item list (I’ve edited the post now). I wasn’t able to reproduce issues scrolling the Add Item list, so if other people were experiencing the issue, I was hoping to gather more details to see if we could find anything in common. :grinning:

I’m sure it’s happening for you - I just have to figure out how to reproduce it!

The add item list works on my iPhone. The edit item does require scrolling to the top, usually scroll anywhere along the right edge to avoid moving tiles. I don’t remember which screen, but sometimes it is difficult to bottom to save/cancel.

Sometimes turning device sideways helps to see Things better if having trouble.

1 Like

Link to video sent directly to Josh by e-Mail. It does not appear I could upload a video here.

1 Like

@Gary_Milne and @kevin we’ve included a number of enhancements and bug fixes for editing on mobile devices and iOS in the latest beta (beta program details):


This includes:

  • The Tile Editor is layered on top of the floating action buttons making it easier to save tile edits on mobile phones
  • ‘Done’ button on Add Item is now visible even with weird iOS scrolling
  • Tile Editor is shown at your scroll location on iOS devices
  • Show prompt to close the Tile Editor if it’s still open when you attempt to save the dashboard
  • Icon Picker should scroll more consistently on desktop devices now

Hey Josh, I have not been doing much editing on my iPad but today I unsuccessfully tried to change the configuration of a dashboard. Basically I could not get to the “Save” button after the changes were made.
You should be able to duplicate as follows:

My iPad was in landscape mode with Chrome:

Edit, Configuration.

I was changing the Tile size to custom (100)

The Save button is off the bottom of the screen at this point so I try to drag\scroll the dialog box up to reveal the Save button.

When I release the dialog so that I can click the Save button, the dialog snaps back (probably to vertical center), the Save button is not visible and now the dialog seems to ignore all of my touches at this point.

So I bail out unsaved.

Thanks for the message - I noticed that this reply came via email. Have you tried the newest beta release? As noted in the post immediately above, there are a number of enhancements related to editing (especially on iOS devices) in the latest beta.

Tried it again on the Beta site and it worked just fine.