Reolink NVR setup for video streaming to the dashboard

Hey there! New member exploring dashboard options for our home.

I have a reolink NVR that I’m trying to plug into a dashboard, and am having some trouble with these instructions. Not a huge technophile so that at least partly explains it.

I have a few cameras routed through the NVR, but haven’t had any luck getting streams from any of them to show. Some questions

  1. I assume all of the parentheses in the address (e.g. http://( IP address ) etc.) should be removed, including around the user name and password.
  2. Is the IP address the one for the NVR on our home network? e.g. 192.168.0.xx? And this is the address listed under the NVR, not the one listed for my username (this may be specific for reolinks).
  3. for the channel number, are we entering “5” or “05” or the channel name?

Appreciate any advice anyone might have!

@N_J_H, welcome to the community, and I hope you don’t mind me moving your post to a separated topic for this specific Reolink NVR settings, so this topic can be found more easily by others who may be interested as well.

This is referring to @Kent’s post where his dashboards and NVR setup is shared.

I can help answer a couple questions here, and @Kent please feel free to jump in.:grin:

You should replace the (IP address) with your Reolink NVR’s ip address (192.168.0.xx). I’d assume the channel name to be just “5”, and you should be able to find out by giving it a try.

If it still doesn’t work, you may want to post the URL you tried so @Kent may understand better the issue(s). (Of course, you should remove/mask the username and password in the url.)

1 Like

Thank you for moving to a new post :grinning:

I’ve figured out the correct URLs, but I can only get a static image on my dashboard. If I set to autorefresh, I get an error message: failed to load image,etc.

I’ve tried to disable mixed media blocking, but no help. Doesn’t seem to matter what I set the refresh rate at, either.

The NVR might not like the ‘cache buster’ that gets appended to the URL.

If you’re using a URL like was shown in Kent’s post…

http://(IP address)/cgi-bin/api.cgi?cmd=Snap&channel=0&rs=kd7f8djlleaijd8sjs9e&user=(User Name)&password=(Password)

You could try the working URL directly in your browser to make sure it’s working as expected, then try manually adding on a cache buster parameter like &st_uuid=123456 and see if the image still works.

http://(IP address)/cgi-bin/api.cgi?cmd=Snap&channel=0&rs=kd7f8djlleaijd8sjs9e&user=(User Name)&password=(Password)&st_uuid=123456

If it doesn’t work anymore, then the NVR might not like the cache-buster parameter… if that’s the case, it won’t work with the autorefresh feature.

1 Like

Thanks for the suggestion. I can paste the URL directly into my browser and it works. If I refresh the page, it refreshes.

I added the cache buster parameter like you suggested in the URL at the web page, and it still worked. Refreshed and still worked.

Added the cache buster to my URL in the media resources page - no change. Still get “failed to update” when the refresh hits.

I’m guessing that it should work - users on other platforms seem to have it working in their dashboards:

@N_J_H, does your username or password have any symbol character like ‘%’, ‘$’ and etc? If so, try to use letter and numeric character username/password again. I am guessing the url parameters &user=(User Name)&password=(Password) are encoded after auto-refresh, and therefore doesn’t match the user authentication requirement anymore.


Yes, it does - @. That makes sense, I’ll give it a shot this evening! :man_facepalming:t2:

That was it! Mark Resolved :slight_smile:


Hello, i’m a new user… and I am a beginner on the subject …
I followed the instructions to connect Reolink Cameras to sharptools, but the tiles remains gray and if I click it tells me dashboard does not exist? Why?
The link, psw, user are corretcs… i tested. Please help me.

Have you also followed the secure content edit? A lot of browsers no longer support logging in with a username and password in the link. You need to allow insecure content for it to work.

Yes, it s correct setting. In the browser i see, but in the dashborad no.
Are there another edit setting?

Can you share a screenshot of what you are seeing?

I don’t know what you mean by the tile is staying gray. And seeing a message of “dashboard doesn’t exist” sounds more like something you would see with an incorrectly configured hyperlink tile than a media tile.

Thanks for sharing. That’s the Custom Tile tool for developers. Is there a reason you’re using that rather than the Media Tiles?

No, how i said i am new to this platform… and i tried to user media tools but do not load the image.

Welcome to the community! :slight_smile:

I included a link in the last post with details on how to use the Media Tile. It sounds like you tried the media tile and the next part could be your issue. :point_down:

Since you’re using Chrome, it will likely block the mixed content by default (HTTP media in an HTTP site). When you setup the Media Tile, it should prompt you with a warning that includes a link explaining how to work around it.

:link:Google Chrome - Mixed Content - Media Not Showing



hello, Ok, I set all the parameters and it works. But after 10 seconds the image disappears.
i am going crazy…

Sorry, i set to refresh every 10 seconds…

Helo, after one day… this is the situation:

  • from Safari i see the image to cam
  • from Android it is not any image
  • from Chrome the image refresh every 10 seconds, but to the 2nd refresh this disappears…