Need help with Eufy cameras on dashboard

I have 4 eufy 2c cameras, 1 eufy doorbell camera and a eufy flood light camera.
I would like to get the doorbell and the floodlight came to show up on my dash board, I’ve tried the tinycam pro app, I can get it to work everywhere but on the fire hd8 tablet I’m using for the dashboard.
I try http and I get a message that says certain web browsers can’t display with a learn more I followed those directions and it still doesn’t work, if I try https it shows nothing and says the site is unsecure.
So im out of ideas all I want is for my wife that works from home and spends most of her day on the phone to be able to see if the person at the door is someone dropping off a package or a friend

Any help would be great, I’m pretty new to the dashboard building

Hi @Kraylon, welcome to the community. :grinning:
Can you share a bit more information of your setup so we can better help troubleshoot?

Do you mean the Media Tile (camera video stream) in the dashboard works in other browsers on other devices (PC, MAC, phone)? Is your Fire HD8 in the same network as “the other devices” and the TinyCam Pro server? Does the camera stream work if you manually copy & paste the camera mjpg url to the Silk browser?

This is mainly for Chrome browser v85+, so it’s unlikely to be the cause of the issue on your Fire HD8 at this point.

I believe TinyCam uses self-signed certificate when the “Use HTTPS” is checked in TinyCam settings, so the browsers users don’t like that (not secure). So I’d suggest to uncheck this option if the TinyCam server is within your LAN where you have control over/secured.

Did you set the TinyCam webserver’s username and password? and what is the URL you used in the Media resource you used for accessing the cameras? (The URL should look something below where the username and password are attached as URL parameters.

http://(ip-address):8083/axis-cgi/mjpg/video.cgi?user=admin&pwd=mypassword

I Uninstaller the silk browser on my fire tablet along with a bunch of other amazon bloat ware, I installed Google play, chrome and other needed Google files, I used automate to do this.

If I enter the web servers ip address into a brower on a different device (smart TV, the fire tablet, a different tablet, laptop and my phone) the tiny cam username and password pops up I log in and I can view my cameras. The media tile is what i can’t get to work in sharptools.

I’ve tried it on chrome, internet explorer and brave browsers where is works using the ip address but nothing changes on sharptools

I did setup a password on tiny cam and have it entered as you listed under the media section on sharptools

I’m also using fully kiosk i followed a video I found on YouTube, but the guy uses wyze and arlo cameras in the video.

Hopefully that’s the info your requesting.

Thats what it shows me on sharptools using http

http://192.168.1.123:8443/axis-cgi/mjpg/video.cgi?camera=6&user=username&pwd=password

Is what I have as the driveway camera in sharptools under media
Front door camera is camera 5

If you copy the URL from your Media Resource configuration in SharpTools, then open a new browser window in Incognito/Private mode and paste the URL in there, does the camera stream open directly?

If it prompts you for the username and password, that means something about the username/password configuration isn’t quite right. Or if it doesn’t load at all, something more fundamental is wrong. :frowning:

The following post also has some helpful tips and screenshots in it:

It might also help to see some screenshots of your TinyCam configuration (like those shown in the linked post). One thing I noticed is that your URL is showing the port as 8443 whereas the standard port in TinyCam is 8083.

Based on your screenshot, it looks like you might be testing on your PC in Chrome. If that’s the case, I’d recommend using the ‘Disable Mixed Content Blocking’ workaround noted in the following post to make it easier to test on your PC:

:link: Google Chrome - Mixed Content - Media Not Showing

I would try the following URL:

http://192.168.2.163:8443/axis-cgi/mjpg/video.cgi?user=Kraylon&pwd=YOURPASSWORD

Again, this will not work in SharpTools on Google Chrome on your PC unless you use the ‘Disable Mixed Content Blocking’ workaround noted in the link above.

I’m using brave brower currently, im trying the incognito method you suggested currently

I haven’t tried Brave, but other modern browsers may have the same issues as Chrome with blocking mixed content. Note that Brave is built on Chromium (the same underlying project that Chrome is built on), so even if it doesn’t block mixed content in the current build, they might block it in the future.

And it works that way

1 Like

Its only showing me camera 1 (Back Yard) though
How do I see camera 5 and 6?

Try:

http://192.168.2.163:8443/axis-cgi/mjpg/video.cgi?camera=5&user=Kraylon&pwd=YOURPASSWORD

Keep in mind that the TinyCam numbering of cameras can sometimes be a bit odd, so sometimes you just have to try incremental numbers. (eg. camera=2, camera=3, camera=4) until you find the one you are looking for.

And I haven’t personally tried Eufy Cams in TinyCam, but if it tries to keep the stream open to the battery powered camera all the time, it will likely drain the battery very quickly.

The Eufy 2C is battery powered and depending on which Eufy doorbell model you have, it might be battery powered as well.

Your correct on the 2c my door bell camera is charged off the old doorbell wiring (24 volts a/c) and the driveway camera is power off 120 volts, so they should be up to the task.

I just added all of them and will disable the ones I dont use on the dashboard

2 Likes

We are making progress, its no longer showing me the “failed to load image” but its not showing me a image, I have it set to auto refresh on sharptools in 30 mins, so I’ll wait and see.

Does the tablet with the dashboard need to be on the same network as the web server?

Yes, the device displaying the dashboard needs to be on the same network as the web server (or at least able to access it over the network).

Note that only devices running Chrome 85+ will display the ‘Failed to Load Image’ warning as that’s the primary browser affected by the Mixed Content issues. Other devices will simply fail to display the image.

Am I understanding correctly that you got the cameras displaying in SharpTools on another device (like your PC), but they’re not displaying in SharpTools on the Tablet?

I figured out my error and its now working thanks for all your help and advice!!

Sorry for the slow response, I meant my response limit

1 Like