Modern Forms Fan with SmartThings

Amazing work ! But in my case, it’s not working properly, it seems that the fan is detected as Low when it’s Off, and if I change the speed thru my dashboard, I can’t turn it off anymore… how can we know the good value to turn it off ? When added to a rules, it seems the proper value should be “off()” but it’s not acceptable as a “custom speed” on the dashboard itself.

What device handler or driver are you using? If it’s a custom DTH/driver, can you please provide a link to the relevant thread?

Most devices should accept a speed that turns the fan off. On Hubitat, that’s commonly a value of 'off' and on SmartThings its 0.

Many fan devices also implement the Switch capability which enables you to use an on() or off() command as you alluded to, but that’s generally separate from the Fan Speed capability. Part of the reason for this is devices may control just the fan or also control a light. So in combo devices, the on/off commands control the light (same as setLevel() for dimmable lights) whereas the setFanSpeed() / setSpeed() command is explicitly designed to control the fan speed. All that goes back to the previous paragraph that a fan should accept a speed that will turn it off rather than relying on the off command.

Dear Josh ! Thank you for the quick answer.

There is no specific DTH/driver because It is an officially supported fan, so it is connected through a linked service into Smartthings. (the fan is a

In the smartthings app, there is an on/off switch and I just realized that there is also and “OFF” fan speed level that turn fan speed back to the previous state… (same behaviour as sharptools dashboard !)

I just fixed partially the issue by creating a smartthings routine that turn the fan “switch” to OFF when the speed “OFF” is selected… the only downside is that the dashboard always shows the “speed settings” so even when the switch is off, sharptools return the previously set speed… but at least I can turn the fan off now :smile:

Do you have any idea to bypass this behavioir ?

Thanks again.

It’s something the device manufacturer would have to improve since they maintain the device integration and how it works.

SmartThings has two levels of integrations:

  1. Self tested by the manufacturer
  2. Certified by SmartThings

The self-tested ones are more likely to have these kind of issues as it’s up to the manufacturer to properly interpret how things should be implemented. The certified ones go through SmartThings, so they usually catch these kind of issues and have the manufacturer correct them before they are public.

You could put together a Super Tile that has icons for each of the speeds you want to use and set the ‘off’ icon to send the off() command. This would be a bit of an advanced setup though as you would need to use a rule to send the different speeds for the other icons.

Ideally, the manufacturer should fix this though as the ‘off’ fan speed should turn the fan off. And if the fan gets turned off (physical button, app, etc), it should update the reported speed in SmartThings to reflect off.

If you figure out a reliable way of controlling them with the sharptools dashboard and routines/rules, please let me know. I have 4 Modern Forms fans on my patio and had to remove them from my dashboard since the dashboard buttons could not control them properly.

If the fan doesn’t properly handle implicitly turning off when the 0 / off speed is sent, couldn’t you customize the fan speeds to remove the ‘off’ speed then add a separate on/off switch tile for the same fan right next to it?

If the device also implements the Switch capability and uses that for controlling if the fan is on or off, you should be able to add another copy of the device to your dashboard and then change the tile layout to Switch Tile or Switch Level Tile.


That might end up looking something like the following:


If the fan is still reporting the speed as ‘medium’ or whatever while it’s off, you’ll probably want to disable the animation on each of your speed customizations. The downside being that you won’t see them when the fan is ‘on’, but you’ll have the tile right next to it to make that more obvious.

Smartthings shows the following speed options for me:

  • Off
  • Low
  • Medium
  • High
  • Max

It also has the power switch in the corner on the ST app tile.

I edited the speeds on a fan speed selection tile and added a switch tile for 1 fan and will do some testing when I get home.

Thanks for the suggestions. Fingers crossed it is a functional solution.

So in the ST app, Off on the speed selector does nothing. So I set up Sharptools for 4 speeds, Low, Medium, High, Max and matched the setup shown above for an on/off switch and it seems to work well and syncs up with the ST app….thanks!!!

1 Like

Bit cludgy but it works. Before the matrix migration 0 was working for Off on these fans for me. Then again, it could have been an MF firmware/software update.

@Jean_Sebastien_Decar and @Philip_Peeples, I have the same issue with my two Modern Form fans so I built a supertile. Touching the fan icon stops/resumes and the high//medium/low turns on the fan (if it’s off) and sets the correct speed. Maybe that’s a solution for you too.