Links not working

Anyone else having difficulties getting Sharptools to launch a URL formatted shortcut? I have tiles built on both Android and IOS to launch apps like Sonos and TinyCamPro using URL formatted links (example: Sonos:// ) that used to launch with no problems. This morning neither my Apple or Android device will respond when pressed to the link. Not sure if this is a recent issue or not since I don’t use these tiles regularly.

Hi Mark,
It’s interesting that none of the URL app shortcut works for you on both iOS and Android. Can you post your links so we can better troubleshoot?

Thanks for the quick response James! I’m currently at work, so I’ll have to follow up when I get home, but the common one on both platforms was for the sonos app:


It was working fine a week or so ago and doesn’t appear to be doing anything this morning. I did load up ActionTiles and try the same link this morning to Sonos and it worked fine. So it doesn’t appear to be anything with the specific link.

Can you tell me more about the devices and browsers you are testing this on? I tried the Sonos:// URL on Chrome on Android P (Pixel 2 XL) and I wasn’t able to reproduce. I’ll try on an iOS device later today.

Can you confirm what the Link Action is for your Sonos Hyperlink tile?

And here’s what my Hyperlink configuration looks like:

Yep that was the problem! Once again Josh you nailed it. I didn’t have the additional options selected in the tile settings. Is this something that was recently added? Don’t remember it before and it seemed to work in the past. Nevertheless we’re back in business. Thanks!

1 Like

Great! Yes the hyperlink tile’s link action was recent added as requested by several users. So it is consistent as the action option in media tile. :slight_smile:

Just to clarify, the Link Action option was added to Hyperlinks in the January 22nd release.

We added the Link Action option to the Media Tile (and News Feed tile) in the March 7th release, but I made a minor modification to the Hyperlink tile at the same time. I see where we can improve the backwards compatibility, so we’ll work on getting that included in an upcoming release. :slight_smile: