Linking android apps to a tile

How do I get it to stop trying to load a webpage?

@Roman_Gurule, what browser are you using and can you post the link you used to open the app here so we can better understand the issue?

It’s fully paid and the one Josh posted above. Just trying to figure the best way to open Spotify on my tablet. New window, same window or open in modal.

If the app intent url is correct, it will just open and switch to the Spotify app directly., instead of treating it like a web page.

I think it’s good now. Seemed to be a lag between what I was doing on the laptop and on the tablet.

On a side note, any direct integration with spotify yet?

Please note that the intent url above would only work within Fully Kiosk Browser (your tablet).

We don’t have any update in regarding to the Spotify integration at this point, but please vote in the following Feature Request to help us collect the interests. :grinning:

1 Like

4 posts were split to a new topic: Fully Kiosk - Quirk After Opening Android App

Hi! I tried this with the Zello Walkie Talkie app and I didn’t work. Why would that be? Could you perhaps try it on your end and see if it works for you? Thanks.

Welcome to the community!

What part didn’t work? Can you share some more details about what you’ve tried?

So I followed the steps you put above and entered the following into a hyperlink tile:


And each time I try to click on the hyperlink tile, it just says “Failed to start another app.”

Are you clicking the Hyperlink within Fully Kiosk Browser or another browser like Google Chrome?

I’m clicking the hyperlink within fully kiosk.

Can you share a screenshot of what your Hyperlink configuration looks like?

The 'x' in your post above appears to be an '×' (multiplication symbol). I’m not sure if that’s just the formatting from the community post or if your hyperlink actually has that same symbol. It must be a normal 'x' and not the multiplication symbol for it to work.

Otherwise the intent URL provided works fine for me in Fully Kiosk Browser:


As noted in my original post above, also make sure that you’ve enabled ‘Open URL Schemes in other apps’ within the Fully Kiosk Settings.

1 Like

That was exactly my mistake; I put the multiplication sign instead of a normal ‘x’. It works! Thanks a lot!

1 Like

Hi Joshua,

Does this work only with Kiosk Browser?
I’m using WallPanel as a browser.
I tired to add Hyperlink as you mention and I open it from my phone on Chrome browser and it ask me to select an open to open with… but Spotify wasnt there.

Can you help?

When I last tested it with Wallpanel in August 2020, the intent URL format was not supported in WallPanel.

I looked through the GitHub repo for Wallpanel and it looks like just recently they’ve added some level of support for intent URLs. Here’s the relevant issue from the WallPanel repo. Make sure you’ve updated to at least WallPanel or newer.

That being said, I played with it a bit and it seems to be a bit flaky compared to Fully Kiosk. Several of my existing intent URLs worked fine, but some didn’t.

Many thanks Joshua, I appreciate it, I will try

Is there a url intent for MyQ app?

Hi All. Just picked up this thread as I was hoping to launch amazon music app from my tile. I also get the “failed to start another app”. I have checked all the steps re settings and I am using Sharp Tools from within Fully Kiosk. Url link is:


Any ideas?