Kindle Fire, Fully Kiosk, Error Sending Command


#1

Here’s the current setup:
Old 3rd gen Kindle Fire HD 7" on Fire OS 4.5.5.3, running Fully Kiosk Browser 1.28.1.

Any time I try to interact with a SmartThings tile, I get “Error sending command”. I’m able to use my dashboards just fine on my PC and phone. Is there a way around this or do I just need a newer device?


#2

Fire HD 7 should work fine. We test against Fire HD 8 devices directly, but I think I have a HD 7 somewhere I can test against if I can find it!

The most common reason for an error when trying to control a Thing is either a network connectivity issue from your phone/tablet running the dashboard or a temporary issue with the SmartThings platform. It sounds like you are able to control Things on your dashboard from your PC, so that’s a good sign.

Are you sure the Fire HD 7 has stable network connectivity? Sometimes devices can try to sleep their network connectivity to save battery. A good test would be to do a full reload of the page and then immediately try to control a Thing. By fresh reload I mean using the reload capability of the browser (not just navigating between pages).

For Fully KIosk Browser:

  1. Slide of the left navigation menu
  2. Choose Exit Fully
  3. Once Fully is completely closed, open it again from your tablet’s homescreen
  4. Navigate to your desired page and immediately try to control a Thing

#3

Thanks for your suggestions, but I have already tried all of this. I just recently discovered that I am able to interact with the dashboard using the built-in Silk browser. I like Fully because if I have to restart the device, I just tap one app and I’m full screen and ready to go. Do you have any suggestions on settings I may need to change or another browser?

Update: I have now tried “Kiosk Browser” from ProCo IT as well with the same error.


#4

Interesting. Thanks for the update. Let me see if I can find my Fire HD 7 and reproduce the issue. :grinning:


#5

FYI, this is not a new Fire HD 7, this is the 3rd generation from 2013 I think.


#6

Ok. Mines a 5th generation, but it’s still worth a shot to see if I can reproduce the issue on it. Wikipedia is light on the details of the third and fourth generation, so I’m not sure how big of a difference those models were. Either way… worth a shot if I can find it.


#7

The short version is the software might be too old on the 2013 Fire tablets and Amazon doesn’t seem to be updating them anymore. I’d like to dig into it a bit more to see what it might be missing and if I can work around it though. :smiley:


Long Version

I did a bit more research and it looks like the newer 7" models are just part of the “Kindle Fire” line whereas the 3rd and 4th generation like you have were technically part of the “Fire HD” line which is only available in 8" and 10" models in the most recent years.

Either way, the key thing that matters is the software version (which you very helpfully provided in your original post)! It looks like Fire OS 4.5.5.3 is equivalent to Android 4.4 (KitKat) and unfortunately that’s the latest version of software provided for the 2013 devices.

Silk is Amazon’s custom browser, so they may be able to keep it up to date via the Amazon App Store which would explain why it works. Unfortunately, Amazon has a tendency of not keeping things like the built-in “Webview” up to date. And since the webview is used for rendering webpages in browsers like Fully Kiosk Browser and other third party browsers, that explains why it might not work on an older Fire OS version.

We included some changes in the last two SharpTools.io platform releases to improve support back to Android 4.4 - now that I think about it @Steve_Jackson also mentioned that controlling things still wasn’t working for him on his older Motorola Xoom with Android 4.4.4 so it may be something that I can reproduce via an emulator and then see if I can work around it. :sunglasses:


#8

Correct @josh. After your updates the screen would populate but I was unable to send command. I got around this on the Xoom by using a version of chromium modified to work on the tegra 2 (which the Xoom is).


#9

If it’s possible to get this working in a kiosk browser, that would be great… but I did sorta-kinda get this working. I stumbled across UC Browser. This is the only browser I could find, compatible with this old Fire HD, that allows full screen and automatically loading previously open tabs. I still have to manually open it if I restart the tablet, and be careful not to scroll up by accident, because it will bring down the address bar, but this should get things going until it’s possible to use a kiosk browser or I get a new tablet. Thanks for the updates!


#10

I’m having this issue as well, on a rooted 2016 Fire 7 (5th gen) using the Fire version of Fully Kiosk Browser. The sharptools dashboard displays and shows updates normally, but I can’t send any commands from the tablet. Sending commands works great from a PC, just not from the tablet.

Loading the dashboard in Firefox works fine, and commands have no issues being sent. From the post above, it sounds like the old webview version is the culprit - but then I’m not clear why it works in Firefox, which is also 3rd party.

Is this an issue that SharpTools would be able to tackle, or is it something Fully would have to fix? The fact that Firefox works makes me think there must be a workaround in play somewhere.


#11

We’ve fixed support for controlling Things on old Android browsers in our development branch and it should be included with the next release. :grinning:

It was tested against Android 4.4 in an emulator, so I expect it will work on the older Amazon Fire and Android devices you guys have mentioned, but we’ll need to get it on live devices to be sure.


#12

Awesome! When is the next round of magic expected to go live?

Also, I’d be happy to do a beta test if you need someone with a 5th gen fire.


#13

I expect it to be released in the next 1-2 weeks.


#14

Sweet. I’ll be watching for it.


#15

@AlixJG @Joel_Kelley @Steve_Jackson

Today’s SharpTools.io platform release includes some enhancements around older Android / Fire Tablet devices and the issue with sending device commands. Be sure to refresh your browser to get the latest changes and let me know if this gets device control working for you! :smiley:


#16

Sending commands works great on my Fire tablets now. Thanks!


#17

Sending commands from my old Fire HD works great now! However, now I have another strange issue. My media tiles that are set to “cover” are doing “fill” on my Fire HD. All other devices, and UC Browser are working properly, but the kiosk browsers are stretching/crushing my media tiles.


#18

Have you done a full refresh of SharpTools.io on the Fire tablet? When the update was first rolled out yesterday, another user reported that the ‘Cover’ option wasn’t working as expected, so we rolled out a hotfix to correct it.

I’m wondering if that device is running the version without the hotfix and needs to be refreshed.


#19

Anyone else having issues changing the positions of tiles? I can create new tiles and change color, icons, etc. but I can’t move tiles around on my old Xoom running Android 4.4.4