Keeping Fully Kiosk Browser "On Top"

This is probably a Fully Kiosk Browser or Fire OS question, but here goes.

I am running ST on a Fire Tablet. I loaded FKB via the .apk for FireOS, so I still have full Alexa capability. So when I have the ST dashboard displayed via FKB and I ask Alexa to turn on lights, for example, the command is executed and the dashboard is still displayed. However, when I have the ST dashboard displayed and I ask Alexa to add something to my shopping list, for example, the tablet opens the shopping list app and the dashboard is no longer displayed.

Is there any way to get FKB to reopen so that I don’t have to manually select it?

Thanks!

Fully Kiosk Browser Controller (DTH)

I’m not sure about this exact use case, but some people have used the Fully Kiosk Browser Controller DTH to get additional control over FKB.

For example, you might be able to use the bringFullyToFront() command to bring Fully Kiosk Browser back into the foreground.

The question would be what you would use as a trigger for running that command. You might be able to just run it periodically, but that doesn’t seem the most efficient.

AutomateIt

The app AutomateIt might be used to accomplish this as well.

For example, AutomateIt has an “Application Status” trigger which can be used to trigger an AutomateIt rule whenever an app is opened.

So I’m thinking you might be able to create a rule that says something like:

IF "Amazon Alexa" app is activated
THEN open app "Fully Kiosk Browser" 
    (with a delayed execution of XX seconds)

The Fire tablets I have nearby me at the moment don’t have voice activated Alexa on them, so I’m not able to test to the full flow.

PS. The Fire Tablets don’t expose the Settings screen for the “Activity Stats” feature that lets AutomateIt know when an app is open.

You’ll have to sideload an app called Activity Launcher. Open Activity Launcher, scroll down and expand Settings and select Apps with Usage Access, then toggle AutomateIt on.

2 Likes

Thanks, gave that a go, for some reason I keep getting a “Usage access required” message on my tablet, when I click on it it asks if I want to complete the action using Show Mode or Setup. If I click either, it doesn’t actually take me to a permissions page to allow the access and I can’t find it in the apps settings. Hmm…

I see it’s a common issue, time to download activity launcher…

I found an easy solution to my problem so I’m posting it as it may be helpful to others.

Hardware: Fire Tablet running ST via Fully Kiosk Browser, with Alexa enabled.

Issue: If Alexa was asked certain things, the weather forcast for example, the tablet would open and display the Weather app. I would have to manually select FKB to re-display the ST panel. (Additionally, after 5 minutes, the tablet would go to sleep, darking the screen, and I would have to swipe down from the top to manually adjust the brightness.)

Solution: In FKB’s settings, select Kiosk Mode (Plus). I turned off all defaults (that I didn’t think I needed) that were enabled except Disable Other Apps.

Result: The ST Panel is now displayed full-time. The screen still darkens based on the timeout, but is re-displayed based on motion. Alexa still works, but not longer pops up another app.

Note: Enabling the Kiosk Mode (Plus) setting will set a automatically set a PIN to go into settings. You can change it, but the default is 1234.

4 Likes