How do I get all the SmartThings options available for a device (Oven)

I’m either on drugs (distinct possibility) or I don’t understand the fundamentals of SharpTools. I’ve tried looking at the help function and searching for tutorials, etc., but I don’t even know how to get started.

I’m trying to create a “tile” to control the oven, with the same options as available in SmartThings. See:

Instead, all I get in SharpTools (if I try to create a SuperTile) is this … hmm, new users can’t upload a second pic? Not sure the rationale for that, but starting to think SharpTools is above my pay grade as I try to describe what I’m seeing, but it seems to be the labels for the Oven Programs in quotations but with no way to edit it, etc.

Hi there - welcome to the community and thanks for posting. To be perfectly transparent, if this is the first device you are adding to your dashboard, you’re gently jumping into the deep end. But we’re here to throw you a life ring if you need it! :slight_smile:

For dashboards, we provide support for a large number of standardized device types like lights, locks, water sensors, flood sensors, garage doors, thermostats, etc. These device types tend to be well standardized and thus have a standard tiles for controlling them.

We also support all device types to some degree as we expose all the attributes and commands that the device reports. These devices don’t necessarily have a standard tile type though, so when you add them to a dashboard, they get added as a Hero Attribute Tile (which can display any attribute from a device).

And as you noted, you can take that a step further by creating a Super Tile which lets you mix and match data from your device(s) and variable(s) into a single tile. It also allows some level of control by exposing the ‘simple’ commands from a device (those without arguments) or you can control a device using Rules which gives you full control over a device.

Super Tiles are more of an intermediate to advanced feature, so please feel free to ask any questions. If you haven’t already played around with the standardized tiles or rules, I can understand that you might have many questions, so we’re here for you! :ring_buoy:

The community software we use has a concept of Trust Levels that’s intended to prevent spam by unlocking more features as you spend more time in the community. I’ve manually bumped up your level so you should be able to post more pictures now. :smiley:

Ahh, that makes sense (x 2).

Thanks for the quick, honest and helpful response Josh!

I only went straight for the oven because it was the one thing my wife could point to that I thought might help justify my new tablet purchase!!

I didn’t appreciate (until your email) that the SmartThings commands have to be “translated” into SharpTools tiles. I just checked with a light and I now see the 99% use case.

This is what I see when I load some of the “oven’s” commands:

TBH, I don’t need my dashboard to be as fancy as some of the ones I’ve seen on here – although never say never of course.

Is there any chance there’s an easy(ish) way to launch a couple of “smart device” Android apps through the SharpTools dashboard? I’m fiddling around with Fully Kiosk and was going to use Sharptools as the single website, but wondering if I can then include a couple of icons on Sharptools to launch things like my Oven app, Sonos, etc. (where I would want some additional control over the devices)?

Or am I thinking the wrong way about how to use the tablet for this kind of stuff? Or maybe my need for Fully Kiosk? I don’t care about locking people out, etc.

EDITED: I just spotted this re: hyperlinked programs and will give it a go!

Yes, it looks like you already found the relevant help article! :+1:

A lot of people like Fully Kiosk just for the fact that it’s a full screen browser that doesn’t show any of the menus or anything from a normal browser. That basic feature is available for free, but Fully Kiosk has a bunch of features and many people find themselves interested in at least one or more of those features as they continue to build out their dashboards.

That’s all super helpful, thanks Josh!

I know there’s a lot of info out there about how to set up a dashboard, but it’s a bit daunting for an old guy like me. Appreciate you getting me pointed in the right direction. I think I “get” where this is all going now!

“Last” question for you, and I appreciate it’s a long way from an oven, so not sure if I should be tagging it onto this thread, but … any chance you could point me to a good post re: setting up a camera feed on SharptTools?

I’ve got TinyCam Pro running a webserver on my tablet and I can see the cameras on TinyCam, but I can’t seem to get the feed to show on SharpTools (tablet via Fully Kiosk or Chrome browser on desktop).

I’ve tried the steps at the below thread (tablet and browser), after clicking on the link that says “Failed to load image. Learn More”, but I still can’t seem to get it to work by allowing mixed content:

If I’m honest, though, I can’t quite figure out the webserver info vs. the camera info.

The webserver info in TinyCam shows:

The camera shows:](

If I plug the camera info in my Chrome desktop browser, no issue seeing the feed.

But, in SharpTools, I’m using the following info based on this linked post and I get that error message above: Media and Thermostats - #13 by josh [and I’ve tried cycling through the camera numbers].

I feel like I’m close, but can’t seem to get this across the line. Anything obvious I’m missing?

Try the format as it works around the recent bug introduced in Chromium 111


Or try the same thing with the camera feed directly.


Took a bit of fiddling, but it’s up and running!!

I remembered you saying in the other thread that anonymous viewing should we enabled. That worked with the direct camera feed (not the webserver) and](

Just in case it’s helpful for others, if you get the right media URL you’ll see the feed pop up as you create the media under Manage Resources. When it wasn’t working, I was going back to the Dashboard thinking I needed to add it there to see if it was working. Just FYI.


1 Like

I think I’m getting the hang of it. It’s a bit of a learning curve with Fully Kiosk added to the mix as well, but I’m well on my way, so thanks again Josh!

Back to the oven.

First, a hint for others that may stumble across this thread (it may be obvious, but wasn’t for me), I realize you can add a second tile and use “Change Layout” to add specific functions. Added a second tile to turn the oven on/off without having to go through the Oven app that launches separately. It also allowed me to change the “function” of some thermostats I have so they report temperature vs. act as motion sensors, thermostats, etc. That was great because my Ecobeee thermostat only reports the main thermostat temperature via SmartThings (which reads high), instead of the remote sensors. So I was able to add a remote sensor and second thermostat to provide the current temperature.

One final “oven” related question? I’ve been messing around with various settings in Fully Kiosk to try and be able to close apps I launch without having to hit the backspace button. The oven settings are a few menus deep in the app. If I try to launch the app by opening in a new browser, I get an error message that says “pop ups and new tabs are disable”. I’ve tried whitelisting the apps, showing the apps on the launcher, launching them in the background on start (it says it fails to load), showing the home button, etc. but can’t seem to figure it out. I’ve got another app that I use that doesn’t doesn’t have a back button and once I launch it, I can’t get back to Fully Kiosk without closing it down.

Any hints or points to a link?


So you’re able to successfully launch the app, but then at some point you see that error message? Can you clarify when you see that error message?

If you were only able to open other apps when using a link set to ‘same window’ and you were then trying ‘new window’ and it wasn’t working, Fully Kiosk has new windows / pop-ups disabled by default if I remember correctly. It might be the Web Content Settings → Enable Popups, but it’s been a while so there might be other settings you would want to enable too. You need the ‘Open Other URL Schemes’ enabled too but you probably already have that set if you’ve opened other apps another way.

Note that opening in the ‘same window’ still opens the app externally, so there’s not a difference in behavior compared to opening in a ‘new window’ if I remember correctly.

You might poke around the ‘Regain Focus’ setting in Fully Kiosk. With that setting, Fully Kiosk can automatically bring itself back to the foreground after you stop interacting with the other app for X seconds:

Sorry, I should have said I only see that message if I open the app in a new browser, but you were right about Fully Kiosk needing that Enable Popups option enabled for the “new browser” option to work. Not sure how I missed that one, but it worked with that setting.

That said, I see your point now that it doesn’t look any different, I thought it would sit in its own window (like in Chrome).

I’ll mess around with that Regain Focus setting. It sounds like that should do the trick.

Thanks again!!

1 Like