Foscam Cameras Don't Work on Dashboards Like They Did

I have 7 Foscam cameras that had all been working on my Sharptools dashboard for at least 18 months, then suddenly, they all stopped being displayed.

In the Media Tile, I have this URL

If I just plug this URL into a Chrome tab, it works fine. I see the camera and it is being displayed. It has something to do with

I’ve tried the “site settings” change to allow insecure content, but that was already on.

I’ve even tried to switch to port 443 and use https:// with the same URL, but I don’t get anything displayed.

What happened to Sharptools about 2-3 months ago that would suddenly change all my tiles?

I’ve run out of things to try, any suggestions are welcome.

If your Chrome updated recently, that’s likely the issue:

Im having similar issue with my Hikvision cams on MS edge, I gave up on chrome for this a while ago. A week ago they worked and now they dont. I can pull the cam snapshot up in a stand alone URL, but it wont display in sharptools media tile anymore. And yes I have unsecure content enabled for these local IP addresses which was working fine for a couple years.

Edge is based on Chromium now too, so the same feedback applies.

So after scanning these responses, what I take away is that Chrome doesn’t work anymore because it has been updated. (I am also running v111.0.5563.111)

Opera worked for a bit, but it has been updated.

Edge doesn’t work.

SSL Certificates are a pain, and not for the faint of heart.

What is it you are suggesting we do? What can we do it restore all the functionality that we’ve embedded into our dashboards?


The third quote from my reply above includes another community member’s feedback on how they downloaded a version of Opera that works along with instructions on how to prevent it from auto updating.

An update to Chromium – which powers Google Chrome, Opera, Microsoft Edge, and many other browsers – introduced a bug that is causing the setting not to be respected. So as a workaround, you can use a browser version from before the bug was introduced to Chromium. Ideally, the Chromium team will resolve this issue so newer versions of Chromium based browsers can continue to be used as normal.

I may just be stupid. I downloaded a version from Dec 22, and then another version from Jan 2021.

Neither one fixed the problem. Neither display the webcams.

I’ve looked in the settings for Opera to see if there is a “display insecure” and based on my web search, it doesn’t look like they have the setting like Chrome does.

How do I go about setting up my Foscam’s with certificates if I can’t get around this browser issue? Without being able to see my webcams, Sharptools is much less valuable to me and I might just drop the whole thing.

Yep, I tried to roll back MS edge and still no go. Cam snapshots work fine in stand alone window, not on the sharptools dash.
Cam Snapshot url

Same snapshot url on dashboard on same browser. Cam IP address is on the browsers allow list

From a quick test, it seems to be roughly the same concept as Chrome on PC. Tap the lock icon by the URL, tap Site Settings, change ‘Insecure Content’ to Allow.


This was on Opera 96. I didn’t try disabling the auto-updates, but Hendre linked to instructions on how to do that (the last quote from my post above).

I don’t have Foscam cameras, so I can’t speak to the details of it, but the overall concept would be to get a valid SSL certificate and install it on the camera (assuming the camera supports that). Alternatively, some people prefer to use a reverse proxy like Caddy, Apache, or Nginx as there’s a lot of articles for those particular reverse proxies describing how to set them up… though it is quite a technical process.

I can’t speak to the Edge rollback process, but I suspect it would need to be less than version 111 and like most Chromium browsers, the auto update process tends to be pretty aggressive. And of course the ‘Allow Insecure’ / Mixed Content setting would need to be enabled for it to work in Edge.

So then are we saying that utilizing Foscam cameras, we cannot use Sharptools on anything but Opera now?


Opera is based on the Chromium project just like many other modern browsers including Chrome and Microsoft Edge. The bug seems to have been introduced in version 111 of these browsers, so some people are running older versions of their preferred browser until this is properly fixed in the Chromium project.

I suspect that some people don’t want to rollback their primary browser (Chrome/Edge) and since Opera was a bit slow to update to 111, it was an easy choice at the time for people to just install that.

1 Like

Regarding the issue on the bug introduced in Chromium 111 that breaks IP Camera images over HTTP, make sure to follow the Mixed Content thread as updates are being posted there including some discoveries that this seems to impact images from IP addresses and there is a workaround with local domain names:

:link: Google Chrome - Mixed Content - Media Not Showing - #9 by josh