Create "Jukebox" Dashboard with Album Art for Echo or Sonos Devices

So just to clarify and sum it up, I can connect/use echo speaks to habitat hub and do the jukebox that way (but I cannot on smartthings)? Is that correct?

1 Like

Yes, you got it.

Echo Speaks still works with Hubitat and can be used for a jukebox dashboard. SmartThings no longer supports Echo Speaks, but you can still user certain other devices for a jukebox dashboard on SmartThings (eg. Sonos)


Got it. Thanks! That was fast.

1 Like

Hi James,

I’m new to SharpTools and have been researching different ways to use it in my home. I like the idea of the “Jukebox” dashboard, but in my research it looks like Echo Speaks doesn’t work with SmartThings any longer? Does that Sounds accurate? I found another thread where users mentioned that it started working again. Looking for a way to integrate my Echo devices.


Yeah, SmartThings killed it. Still works on Hubitat though.

Bummer. Is it worth switching to Hubitat, not just for this functionality, but comparing Hubitat to SmartThings, is one better than the other?

They each have their pros and cons. SmartThings is easier to use out of the box and has more cloud integrations. Hubitat has taken the crown with community code so there’s lots of unique integrations. What kind of devices do you plan to use?

The normal stuff like lights, locks, thermostat, etc., but I’m interested in the Jukebox and integrating controls of my pool equipment. I’m also having a hard time getting my cameras to display.

If they are zigbee or Z-Wave, you’ll probably have decent compatibility with SmartThings or Hubitat. For Wi-Fi devices, it depends on the specific model.

I followed these steps and it is working…sort of. I added two separate playlists and unless I pause the music before switching playlists, the same playlist will continue to play when I click the other. Anyway to fix this?

Hi @Charlie_Barham, welcome to the community. Do you use SmartThings or Hubitat, and what smart speaker(s) do you have?

I use smartthings and have a beam and 2 play:1 speakers. It now rotates between the two playlists every time I hit next song.

@Charlie_Barham, thanks for the details. I believe this is the same bug raised by @Mike_O that the Sonos queue is not cleared when another playlist is selected, and this new playlist will just be added to the end of of the existing queue.

@Mike_O has reported this behavior to SmartThing support and SmartThings support team did confirm it as a integration bug. See below for Mike’s post in the SmartThings community, and I’d suggest you to post your comment in the thread, and open a SmartThings support ticket as well to help SmartThings prioritize the tasks.

I’d guess the shuffle is enabled so it kind of rotates between two playlists every time you hit next.

Thanks for the help! seems like there is no fix for it right now.

@Charlie_Barham, can you try to add a stop command before the playPreset command in the rule? See below that you can reorder the commands by holding the image icon. So it should quickly stop and then play the new playlist.

I tried that but it still mixes the queue with both playlists.

It’s definitely a smartthings issue because when I use ST app to change playlists it does the same thing


So I’ve done some playing around and what I found is interesting. I have a single Sonos One in my bedroom and I set up the jukebox dashboard for that speaker separately and the playlists work perfect. What gets really interesting is if I start playing music through the dashboard on my single bedroom speaker and then group the living room (beam+2 Play Ones), I can then un-group the bedroom speaker and the playlist selection begins to work as expected on the living room dashboard without mixing playlists together. Seems like the issue only happens when you have multiple speakers paired together for some reason. Still hoping to find a long-term solution so I don’t have to open the Sonos app.

EDIT: Just tested in the smartthings app with the single speaker setup and the play favorite feature works normally without mixing playlists together.

1 Like

I solved this issue! I deleted all my speakers from Smartthings, I then went into Sonos and removed the surrounds from my beam. I then added Sonos back to Smartthings so all my speakers were added individually. Then I authorized all the speakers in Sharptools. Once that was done I added the surrounds back to my beam in the Sonos app. I had to fix all the rules for my playlists but everything is working now, no more playlist mixing!! Hopefully this will help someone in the future.


Just had the exact same issue, when I took off shuffle it seemed to fix it but also have issues now where smartthings can see status of my Sonos Move but the controls don’t work. Conversely if I control the group through my Sonos One it works fine. I’ll try removing and re-adding them back to ST like you tried. Thanks

1 Like

No problem, let me know if you need help/clarification.

1 Like