Camera feed doesn't work in media tile

I’m using Unifi cameras and want to display camera feed in Fire HD 8 tablet with Wallboard. I followed some instructions on how to set this up using the camera’s IP address. If I type the camer-ip-address/snap.jpeg in Chrome it displayed the snap just fine. Doing the same in the media tile doesn’t display the image.

I have enabled allow insecure content in Chrome. I have read about using, however, I am not sure I am doing it correctly. Do I have to have a port after the portion I append?

Thanks in advance.

Yes, you need to include the port.

I would recommend reading through the original thread for more details.

:page_facing_up: Google Chrome - Mixed Content - Media Not Showing

Ok. Thank you. Sorry for the potentially dumb question, but how do I find out what port it uses?

Edit: So I’ve found that supposedly the Unifi cameras use port 80. However, trying to obtain a snapshot using still doesn’t seem to work.

Does that work when you enter that exact same URL directly into a browser like Chrome? Is the full URL: 

(port 80 is automatically implied with http://)

Just to be clear, I’m suggesting that you test the URL directly in Chrome, then test that same URL in a media tile in Chrome. Of course, that instance of Chrome will require the Mixed Content settings adjusted as discussed previously.

I would suggest starting your tests from a computer where it’s easier to make a blanket allowance for insecure embedding for all of (compared to Chrome on mobile which requires an allowance per ‘origin’ of each camera).

Then I would recommend testing in Fully Kiosk Browser as the settings for allowing Mixed Content is documented and well tested by the community.

Testing from a computer it works if I enter the URL http://camera.ip/snap.jpeg
But if I enter the URL it give me a “this site can’t be reached” error.

I can’t get the image to show up in a media tile using either URL. I have allowed the mixed content settings in the Chrome browser for

Hm. Normally if you browser or upstream DNS provider was having trouble resolving the address, you would expect to see an error specifically related to DNS. If they are local IP addresses and you want to share screenshots of the working URL in your browser and screenshots of the not working URL in your browser, perhaps that would shed some light.

What about if you try one of the other wildcard DNS options directly in your browser?

This is the image snapshot that works correctly with http://camera.ip/snap.jpeg

This is the error message with added

I also tried it with the other 2 wildcards and Same results.

Ah, the screenshot shows the additional details: DNS_PROBE_FINISHED_NXDOMAIN

It seems like a DNS resolution issue of some sort. I would check the DNS resolution settings on your router (or on your computer if overridden there).

Alternatively, if your primary use-case is for display on a tablet, you could try the camera snapshot address directly in Fully Kiosk Browser (without the wildcard DNS resolvers) with Fully Kiosk configured to allow Mixed Content always.

That won’t work on Chromium based browsers on versions newer than 111 thanks to the bug the Chromium team introduced with Allow Insecure and local IPs though…

Well crap.

Can’t seem to get it to work from any device.

Can you share more details?

  • What URL format did you try?
  • What type of device / browser?
  • What about the Mixed Content configuration on that browser?

Can you share more details about your network / DNS configuration?

One other user ran into a similar issue with an old ASUS router they had configured with DD-WRT where the wildcard DNS wasn’t resolving for them. When they took that AP out of the loop, things worked fine.

Again, it seems like a DNS resolution issue for the wildcard DNS providers, so tracking down why your router or upstream DNS resolver is having an issue resolving those addresses is where I would focus.

Ok. So it probably has something to do with the pihole that I have setup on my network. Unfortunately, I am not sure I understand enough about networking and routing to change the proper settings. I’ll have to look into it.

I do know that I cannot reach the snapshot using http://camera.ip/snap.jpeg from outside my home network. I have setup port forwarding through my router for this camera but still does not seem to work.

Edit: Ok. It has something to do with Unbound DNS server that I had setup in pihole. I have changed pihole to use Google’s DNS servers and it is now working using

1 Like

Thanks for the update and thanks for sharing the resolution!