Advanced Background Settings and Premium Album Art Tile

Great job guys on the Album Art Tile! Looks great on my wall mounted tablets. Unfortunately just realized that HE only gets the track info if it is a single speaker or the group leader in a group. Been researching for a work around but haven’t really found anything yet other than keeping that speaker as the leader in any grouping.

1 Like

@josh @James Is it possible to create a pop-up menu to choose which speaker to play music on? This could be similar to the “routine picker”. Thanks. Great work!

1 Like

@Robert_Bourne that would be neat. What kind of speaker device and on which platform?

For me Sonos and IOS. I saw some threads on launching the Sonos app from a dashboard but haven’t played with it yet. In my case just displaying the album art is way cool. As for control, I usually use Alexa to control my Sonos or the app on my phone.

1 Like

I have Amazon Echo speakers on SmartThings

1 Like

A post was merged into an existing topic: Album cover art doesn’t always appear

So worked on adding the Premium Album Art Tile for hours last night with major headaches.

Then it dawned on me today what the issue might be.

To clarify I am using echo speak, and have a lot of echo devices. I was trying to control my “everywhere” group that links them all together…and could get it to control the devices (very slowly) but no artwork.

I changed it to just control my main living room device, and it now works perfectly! No idea really why this is, so if anyone has input that would be great, but I am happy for now! I love this tile!

3 Likes

I am having trouble getting the album art displayed. I tried editing the main parent echo speaks app, and just pasted in the code from above, but I get an error message. Is this that the correct way to fix this issue, or am I doing something wrong?

Hoping to get some help with this before my premium trial runs out. The cover art and ability to make a music panel is what made me want to switch from actiontiles.

@Brandon_Green thanks for posting and welcome to the community! Can you clarify what you’ve tried with Echo Speaks?

You mentioned that you tried editing the Echo Speaks app and pasted in the code above, but I’m not sure which code you’re referring to as there’s a few different device handler code snippets linked above.

Did you already have Echo Speaks installed? If so, which version are you running? If you’re using the latest 3.5.0 version of the app + driver/handler, then it should have all the changes needed to support Album Art.

If you already had an older version of Echo Speaks installed when you authorized the Echo device to SharpTools and you’ve recently updated to the 3.5.0 version, make sure to reauthorize the device in SharpTools, so the system can pull down the latest device information. :slight_smile:

How To Reauthorize Devices (tap to expand)
  1. Navigate to your SharpTools.io User Page
  2. Tap Manage Connections
  3. Select SmartThings (or Hubitat)
  4. Follow the authorization prompts
    Note: make sure your desired Echo Speaks devices are checked during the authorization flow.

@Brandon_Green, I just noticed the AudioTrackData capability was commented out from the link I post earlier in this thread, but as @josh has mentioned, the most recent version v3.5.0.0 should be good. So try to update your Echo Speak DTH again using v3.5.0.0, and re-authorize the device to SharpTools.io again.

I also updated my post earlier in case some one finds this thread later.

I had installed echo speaks from code, but did not authorize within sharptools at the time, then I deleted echo speaks. I then re-installed echo speaks utilizing the community installer, thinking it would be easier to stay updated that way. I’m currently running the 3.5.0.0 version of echo speaks but still getting just the default headphone picture with no track info displayed at all. I just tried authorizing again, eventhough I already had the latest version prior to authorizing the first time. The code I was referring to was the one you directed stan to, which was the modified version. I didnt realize the version of echo speaks I was running should include the album art. Wonder what it could be?

Can you go to https://graph.api.smartthings.com/ and verify if the Echo Speak device is getting the audioTrakData correctly when you play some music? (Login with your SmartThings credential, go to “My Locations”, selected the correct location, and go to “My Devices” tab, and click on the Echo Speak device you are working on.)

If the audio data shows correctly in ST, then verify if the data is sent over to SharpTools.io by going to the user page. In the “Authorized Locations” list, tap the “…” next to your ST location, and tap the Echo Speak device in the Things list, and you should see the AudioTrackData displayed in the black text, if you have added it to any dashboard (so it is subscribed).

Troubleshooting Tips:

  1. If you don’t see AudioTrackData in ST IDE device page, update the DTH so it supports AudioTrackData capability

  2. If is shown in ST IDE, but not the SharpTools device page, re-authorize the device to SharpTools

  3. Play music from Spotify or Amazon Music for few seconds and verify if the AudioTrackData (or any attribute) is updating in ST IDE. If not, check the Echo Speak Server, and it may need an update.

    Note: it may take 2-3 seconds before the audio data is sent from Echo to SmarThings/SharpTools.

1 Like

So this must be my issue, I do not see audio track data even listed. So how do I update the dth if I already have the latest version of echo speaks?

@Brandon_Green, you can go to SmartThings IDE site, “My Device Handlers” tab, select “Echo Speaks Device” to review the DTH currently used, and it should looks like the screenshot below.

If you want to update the DTH, copy everything from the link below, paste it to the DTH view we saw earlier, hit Save, and Publish.
Echo Speaks DTH

You can also verify the Echo Speaks version from the classic app -> Automation -> Echo Speaks

And don’t forget to authorize it to SharpTools.io again after you verify the AudioTrackData state shows up in ST device page. :wink:

1 Like

I updated the code from the link you sent, re-authorized, and still not working. The code you sent was for version 3.2.0.3, was it supposed to be for 3.5.0.0 instead? Here is what echo speaks looks like now in my classic smartthings app.

1 Like

Ok so I ended up getting the version 3.5.0.0 device handler code from the echo speaks documentation, re-authorized, and I’m seeing album art and track info now. Thank you so much for steering me in the right direction. I’m excited to start fine tuning these panels now.

4 Likes

@Brandon_Green, glad you got it working, and don’t forget to share your dashboard design in the Show off your SharpTools dashboards thread when it’s done. :grin:

1 Like

Hi guys. I have added the album art feature but at the bottom of the control tile the track description is not updating. It seems to be stuck on the first preset that I used.

Welcome to the community and thanks for posting, @Alex_Camenzuli! Just to confirm, you’re referring to the track information shown at the bottom of the Music Player tile as indicated by the red arrow in the following screenshot, right?

What type of device is this (eg. Sonos, Echo Speaks) and is it on Hubitat or SmartThings? Have you tried verifying directly in SmartThings/Hubitat that the trackDescription attribute is updating as expected?