Advanced Background Settings and Premium Album Art Tile

The official Sonos integration or Echo Speaks?

Echo speaks (20 char)

Thanks, Jimmy. I sent you a PM.

When I took a second closer look at your screenshot, I realized the Album name is being reported as ‘Apple Music’ which doesn’t seem right. My guess is that’s contributing to the issue, but I’d like to gather some more details via PM if you don’t mind.

Just wanted to update the thread that we’ve pushed an update to production that should improve Album Art Tile compatibility with the Echo Speaks device. :smiley:

Thanks again for reaching out, @Automated_House!

Edit: And James submitted a PR for Echo Speaks with some enhancements around the reported track data, so be sure to manually update your device handlers / drivers as well.

1 Like

As of the latest edit of this post, the latest official Echo Speaks version ( includes the enhancements to support Album Art in! You can now update easily using your preferred method (eg. Community Installer, SmartThings IDE, Hubitat Import URL, etc).


Playing with the album art layout. It will only work when music is playing. As soon as it stops, the tile disappears. Also, can’t add new sonos tiles unless you get something playing first. Any fix?

The whole tile or just the album art? Mine shows a headphones icon when music is stopped.

1 Like

Thanks for the report @Andrew_Berg.

The issue appears to be limited Hubitat Sonos devices. I was able to reproduce and resolve in our development environment and will work on getting a hotfix out.

Hotfix has been deployed for Hubitat Sonos devices and the new Album Art Tile. :smiley:

1 Like

Am I blind or where is the option to add media tile? I am using Echo Speak if that changes anything.

To use the Album Art Tile with Echo Speaks, you’ll first add the Echo Speaks device to your dashboard and then use the Change Layout option in the tile’s ... menu.

Note: It looks like the ‘Audio Track Data’ capability needed for Album Art was commented out in the Echo Speaks 3.2 release. Make sure to uncomment the line capability "Audio Track Data" in your Echo Speaks DTH, publish it, then reauthorize it in SharpTools to ensure the album art feature works.

(We’ve also submitted an update which hopefully tonesto7 will get integrated directly)

Update: The latest Echo Speaks releases include support for Audio Track Data and the SharpTools Album Art Feature (version as of this edit).

Oh I thought I already added the speakers, but will double check now when I get home. Thanks!

So I have updated the device driver on Hubitat but and added the echo devices to Sharptools

Yet I do not see any option to select them as a tile on the dashboard, where am I going wrong?

Try reauthorizing starting from SharpTools.

  1. Open your User Page
  2. Tap Manage Connections
  3. Select Hubitat
  4. Follow the authorization prompts

Edit: Also note that Hubitat won’t let you save a device driver with capability 'Audio Track Data'. We’ve submitted an update to Echo Speaks to add the audioTrackData attribute directly to the driver, but it hasn’t been included yet. In the meantime, you can use this modified version.

As of this edit, Echo Speaks ( should supports the audioTrackData property in Hubitat and should work out of the box with Hubitat or SmartThings and the Album Art Feature.

Mmmm nope still not showing. So I have echo dots set up with Echo Speak, they should be showing up?
EDIT: Seems to be working now :slight_smile:

Sorry Josh, just another question. Says to edit the DTH to get album art work to function however when that is done I get this error
“Metadata Error: Capability ‘Audio Track Data’ not found. on line 26”

Please see my note from above. Hubitat doesn’t accept the Audio Track Data capability, but the audioTrackData attribute can be added directly and it will work.

See the link above for a copy of the driver which has the attribute already added for you. :slight_smile:

Sorry Josh missed that. I however just decided after finding another post of yours was to just have a button that opens up spotify via FKB and that works really well for what I want, but thanks again for the help!

Josh - have installed the updated driver and reauthorized it in SharpTools. Still getting just the headphones. Have only tried it playing Pandora; assumed it would have album art.

Hi Stan, I assume you are referring to Echo Speaks?

It looks like one of the Echo Speaks updates removed the Audio Track Data capability which is needed to show the album art. You can use the following linked version which works on both Hubitat and SmartThings: