Add Hikvision camera to SharpTools

I’ve just tried to add my Hikvision ip camera (substream MJPG) to sharptools dashboard. I added the stream (manage resources/media in this format
http://user:password@ip-adress/Streaming/channels/102/httppreview.
Unfortunately without luck.
I can see this stream in Chrom very well. Can you help me?

Check out the following help article for some tips:

1 Like

Thanks for your quick reply. I can see the stream in chrome browser very well. I can’t see it in sharptools.

That is expected. Take a look at the article as it addresses the issue and has some suggested workarounds. :slightly_smiling_face:

While this works fine when you access the URL directly in a new tab in your browser, it may not work when embedded into a dashboard (or any other page) as some browsers like Chrome have begun blocking the use of embedded resources which have usernames and passwords embedded in the start of the URL.

You can find more details on the reasons why browsers are starting to block this format this in the following blog post:

https://medium.com/@lmakarov/say-goodbye-to-urls-with-embedded-credentials-b051f6c7b6a3

does this problem also affect fully kiosk browser? My cameras in sharptools don’t work in Fully Kiosk, Internet Explorer and Chrome browser. As I understand all browsers are blocking embedded streams with password and there is no chance to use sharptools, correct?

I use cameras without NVR.

There are workarounds listed in the linked article.

I tried all of them without luck. Even the article Display Wyze Cam on Dashboard through Blue Iris doesn’t work.

@Serge, can you please provide more details of what you have tried and the specific results, so we can better help? Did you actually setup a Blue Iris server? If so please let us know the setup details.


From the screenshots posted, it doesn’t look like it is going through Blue Iris. Have you tried temporary disabling the username and password requirement to start with?

The credential might be cached in your browser when you accessed the camera’s path directly in the browser.(I assume your first screenshot was to show that you could access the camera without having username and password in the url?) Try to access the camera path using browser’s incognito mode to tell if that’s the case.

1 Like

I had username and password

I have no idea where(

I disabled RTSP Authentication

Or should I do here?

Unfortunately without luck too(

Can you try to use the base64 encoded username and password in the following format?

http://192.168.178.30/Streaming/channels/102/httppreview?auth=XXXXXX

You can get the “XXXXXX” part by going to https://www.base64encode.org and encode your username and password like the example below, and use the encoded value to replace the “XXXXXX” from the url above.

Here is the update for others who visit this thread later that the ‘auth=XXXX’ with base64 encoded username and password trick may not work for newer camera firmware, and the original post was able to get it working through Blue Iris.