Wyze or Yi cams not showing in kiosk browser in Hubitat

I just setup 2 Wyze Pan cams and 1 Yi 1080 cam, all 3 show inside sharptools and URL pasted in chrome. I have sharptools set to kiosk inside Hubitat, I see all 3 Cam tiles but no video. I have been messing with settings and https seems to work best for these cams, but not being able to get live video or even an image is frustrating.

Any help would be great.

1 Like

Apple or Android? Do they show in the normal browser on the same phone?

I am on iPhone/iPad, Sharptools is in hubitat as a custom Dashboard using kiosk view. I just now pasted URL for cams URL string (https://192.168.x.xxx:8083/axis-cgi/mjpg/video.cgi?camera=1&user=admin&pwd=password)

It shows live feed in brows via iPhone fine.

That is a non-routing address i.e. an internal address. Are you at the same location as the cameras, with WiFi turned on and connected to the same router as the cams?

I am on same network, and I blocked my ip in this chat. this is the setup string as shown in sharptools. ID & PW also blocked for safety.

Also the ip is for the point to tinycam pro webserver

Is there a different way to setup cams within sharptools?

This may help in the event the browser is blocking the credentials:


odd thing is viewing dashboard in sharptools itself, all 3 cams show up in each tile created, just can’t see on iPhone, iPad or Galaxy tab

It’s possible that it’s a mixed content issue as well. Some workarounds in the following thread:

tried that, still no change, let me try to go deeper on how I have setup.

  • I am running a raspberry Pi with LineageOS 19 with tiny cam pro.
  • cams are setup in tiny cam pro and are visible
  • tiny cam pro webserver is enabled and am using webserver IP to setup in sharptools dashboard media tiles for each of 3 cams.
  • on PC I can see the cams on sharptools dashboard just fine, also using same URL of webserver direct into chrome I can view each cam fine.
  • I have view kiosk as a custom Dashboard saved in Hubitat settings, so that when I open hubitat it opens as Sharptools.
  • this is the only place where I can’t see the live feed of cams.

I can also ONLY see the live feed via Browser version of sharptools on my PC (hardwired), anything I have that is WiFi connected isn’t showing no matter how I am viewing, I.E. Chrome, hubitat or Safari.

It seems the common issue is within the WiFi connection. Where for some reason its being blocked.
just not sure why, I have IP’s to ALL devices set to DHCP reservations and port forded all cams, hubitat device, etc

I have noticed in my travels that some video devices struggle with new wifi6 protocol, unsure if this could be reason.

Are you able to access the TinyCam stream directly in the various browsers on the various devices? Keep in mind that mixed content blocking only occurs when HTTP content is served within HTTPS content.

So if you try to access the media streams directly in the browser, that should provide a clue if the devices fundamentally have some issue accessing TinyCam (eg. networking or something else) or if it could be a browser issue like mixed content.

on HW PC I see cams when pasting URL into Chrome even before making changes to mixed content.

when I do same on a WiFi connected device, I can’t see the stream. This I am not sure the reason why.

Just to confirm, which URL are you referring to?

I was suggesting using the raw camera stream directly in the browser of the Wifi devices (the URL below). Are you saying that’s what you tried and it’s not working? If so, you could be right that there’s some sort of fundamental networking issue preventing those devices from talking to TinyCam.

What does this actually mean? as far as the http and https is referred?

I changed where currently the only place to change is on webserver settings of tiny cam to enable/disable https

I have set this to enable https currently, I have disabled this also and changes nothing to issue.

wyze and Yi don’t have settings for https stream

In TinyCam you would normally leave this disabled… otherwise it’s serving the content over HTTPS, but it’s going to be an invalid content type.

The first thing I would want to figure out is if you can access the camera streams directly in your browser (no SharpTools involved at all). If you can’t access the TinyCam stream directly, that could point to a more fundamental networking issue.

So your saying input IP of the cam itself into browser? with its port#

Yes, basically whatever you are entering as the URL in the Media Resource configuration in SharpTools.

You should be able to take that URL and put it directly into your browser’s URL bar on all of the device (PC + Wifi devices) and they should be able to see the stream. If they can’t see the stream when you use the URL for TinyCam directly, then there’s something more fundamental that isn’t working as expected and that would need to be fixed before it would work within SharpTools on those devices.

Yes the URL above is the string as described in several documents for tiny cam integration. I only changed sections of IP to not have to post full IP

this is what is set currently: https://192.168.0.xxx:8083/axis-cgi/mjpg/video.cgi?camera=2

and when I paste into browser I see the cam, I just tried on iPhone and I see cam, but it started with the safety warning 1st “click here to proceed”

What about if you disable the SSL in TinyCam. As mentioned above, that likely is causing some issues as the certificate is invalid and you have to manually accept it as you experienced.

Edit: Just an update that we worked together via PM and got things working. Had to flip the HTTP setting off in TinyCam and restart it to get things working. As Myke mentioned, “when in doubt, reboot it out” :laughing:

1 Like