Wyze Cam and Sharp Tools

Im trying to get my Wyze cam into Sharp Tools. I have Tinycam Pro and added the camera successfully in there. created a web address and added it as a tile. Worked fine for a minute then it just froze. Now in Tinycam app it cant connect to my camera. keeps saying “P2P failed to start session”. Shows 0 fps displayed or received. Opening up the address on the computer wont bring up a live feed either.

Update: I have changed the Codec settings to hardware instead of software in the tinycam app. When checking the connection after a bit it was showing its running at about 15 fps and looks all fine but as soon as i exit out of that and go to live view it just freezes and then disappears.

What kind of hardware are you running this on? (eg. what make/model Android device)

I’ve found that the best Video Decoder setting in TinyCam vary for different devices. On some devices, I’m using Software, some I’m using Hardware (and I’m sure Hardware+ works best for some devices).

From the TinyCam website (manual):

H.264/H.265 decoder

H.264/H.265 decoder to be used for video decoding. By default, software one is used. Hardware (recommended) and Hardware+ decoders are available for Android 4.3+ devices.

NOTE: Switch to software decoder if hardware causes the app crash.

You might also try using the ‘substream’ if you are having performance issues with the main stream.

The only time I’ve seen this message in TinyCam was when my wife and I were both using my Wyze credentials. I ended up sharing the cameras with her directly in Wyze (on her own account) and now she just uses the Wyze app and we haven’t had P2P session related messages.

I think i got it to work. Well sort of. Think the issue i was having last night was due to my internet connection playing up a little and causing some weird issues. I have TinyCam installed on my phone but i seem to still have issues with connections with this. I then installed it onto my tablet i use to run my dashboard but it didn’t like that at all. It fixed the connection issue with sharp tools but the tablet couldn’t handle running TinyCam in the background and trying to launch my panel as well. I don’t know if there is a work around for this? The tablet isn’t very powerful just a cheap one that was only going to be used for sharp tools.

Yeah, running TinyCam on a reliable device can save lots of pain and time. The developer of TinyCam actually recommends Nvidia shield to run TinyCam. It’s not a cheap box by any means but I have seen lots of good feedback about it.

1 Like

James hit the nail on the head. TinyCam is great a client on a wide variety of devices… but if you want to use TinyCam as a server to streaming video to your dashboards, it’s preferred to use a dedicated device with a bit more power. (As James noted, the TinyCam developer recommends the Nvidia Shield)

@Jeff_Fourman switched over to an Nvidia Shield for his TinyCam server and it sounds like it’s working well for him:


I just want to mention, that I installed TinyCamPro on my actual tablet that I’m using Sharptools to display my home automations. you just need to use the loopback address / point the media link to:


Hi my friend, I am planning the way for my Wyze Cams V3, so I wonder how TinyCam Pro worked for you in your tablet ? I would like have the wall dashboard panel (tablet) also as the TinyCam Web Monitor server, but I have reading that tablets could be painful to use them as this…
Also I have the option to get a cheap Android Mobile to do the job… Thanks for share !


Hey, sorry for the response, as I didn’t get any notification.
Previously I did have an old tablet with Tiny Cam Pro (TCP) and Fully Kios working, but I got several new Fire HD tablets for the bigger screens. I didn’t have any issues with my previous setup, but the fire HD would not handle the load of TCP.
So my new setup is as… I have an old phone that is acting as my Tiny Cam Pro (TCP) server. I disabled as many programs and services on that Phone so it’s just dedicated to TCP. I installed RTSP on the Wyze cam v2 (except for V3 as there is no firmware for RTSP yet) so that the data doesn’t have to travel over the internet to TCP.
This setup is running so smoothly. I do have a rule on my TCP Phone server to restart every night at 4 am.
I think in the future, I will try a firestick 4K and have TCPrun on that and get a dedicated ethernet cord for that so that TCP will have 0 packet loss or as minimum as I can get.


I have a similar set up using a dedicated android phone as the TCP web server but I did not enable RTSP on the cameras.

It has worked reliably but there is a noticeable lag when I open the sharptools dashboard before the cameras update.

I would love to switch to the NVIDIA but it’s not in the budget at the moment.

1 Like

Thanks Terri !..Im thinking use also an Android cheap phone as the TCP server, but …If you cannot go over RTSP then how you get camera images ?

Wyze cameras work directly with TCP. No RTSP required.

1 Like