Weather Tile - How to Setup?

Sorry, new to this… I can’t see how to add the weather tile… Where do I find this please?

In order to add a weather tile to, you’ll need to have a compatible weather device setup on your hub first.


For Hubitat, there’s several different community drivers available with the Matthew weather driver being quite popular.


For SmartThings, you’ll need to have the built-in SmartWeather Station device installed. You can add the SmartWeather Station from the SmartThings IDE:

  1. Login to the SmartThings IDE:
  2. Go to the Devices tab
  3. Click New Device button in top right corner
  4. Choose whatever you want for name and network id. Change the type to SmartWeather Station Tile. Choose your location. Leave everything else alone.
  5. Click Create.

Note: If you don’t have a zip code / location specified within your SmartThings account, you may also need to edit the newly created device’s preferences and specify a zip code.

Update Your Authorizations

When you’re done, be sure to authorize the newly created device from your user page and then you be able to add it to your dashboard and it will show up as a weather tile as shown in this thread:

Music, Weather, Spacers, and Media Tiles

Alternative Approach: Media Tiles

Alternatively, you can use Media Tiles to display weather information as shown in this help article:

Nice one!! Thanks again!! Super support for this!!


Hmmm I get NA… where have i gone wrong?

Hi @David_McNae, can you post a screenshot or provide some more details? So we can understand the issue better. Thanks.


Sure, so ive made the weather tile in my Smartthings IDE as advised above, then added it to my dashboard. I assuming ive done something incorrect to get the result I have.

It seems the SmartWeather Station may not be configured properly and not pulling any data, therefore it got nothing to show in the SharpTools weather tile.

Can you open the SmartThings Classic app, find your Weather Tile in device list, click on the gear icon at right top and fill in your zip code info and save?

You may want to double check the SmartWeather Tile device’s installation steps just in case.

Once it starts to work, you should be able to see the Current States like this in SmartThings, and it should be displayed properly in then. :slight_smile:

Hi, i’ve added my postcode as im in the UK, assume this will grab data if in the uk?
Will double check the other parts as well!.

It sounds like a number of UK users have been posting in the SmartThings community that SmartWeather hasn’t been updating for them recently.

Another alternative is to use Media Tiles to display a weather forecast from a local news site or use an image from

Widgets from have been popular since our release of background images and transparent tiles since you can set the background color of the image from to transparent.

1 Like

I’m using my Netatmo weather station but what displays on the tile doesn’t seem to correlate with what the Netatmo app is telling me. I’ve added my post code in the ST IDE but not a weather station ID. Is the ID something I should get from somewhere, or is it something I can just make up for a label? Also, the wind speed is in kmh and I can’t find where to swap it to mph.


The first troubleshooting step I would take is to make sure that SmartThings is reporting the correct value since SharpTools receives its data from SmartThings (or other connected hubs).

The Weather Station ID isn’t required. You’ll want to leave it blank for the zip code based polling to work.

SmartThings sets the wind units based on the temperature scale selection. I guess they’ve assumed that °F → MPH and °C → KPH

1 Like

Thanks for that. I think there’s something odd going on. Smartthings isn’t reporting the same as the app, either. I’ve also got this weird thing where I can’t adjust my heating from SharpTools, only see the temperature, as the device doesn’t have the thermostat capability. I think the next step will be to delete my app from Netatmo, delete the devices and handlers from ST and start from scratch.

1 Like

Ok, I’ve got a bit further with this and have a weather tile working. The only thing that’s annoying me is the location label. It looks as follows:

As you can see, it says Andover, null GB. I can’t for the life of me find how to edit this. Any idea?

You can always modify the label of the tile when you add it to SharpTools. :grinning:


Yep, sorry. The penny just dropped with that!



Ok, I thought I had this one nailed. I added the weather tile fine. However, it doesn’t seem to have updated since I first installed it a few days ago. Is says it was updated but the values are all still the same.

@andy, do you mean the weather tile in SharpTools is not updating or the weather station “device” is not updating in ST? If it is updating in ST, but not SharpTools, please take a screenshot of the device attribute list in SharpTools user page → click on “…” next to your Authorized Location → and click on your weather device.

It should look like this.

So I can verify if the subscription is correctly set in SharpTools. Thanks.

Sorry, I should have checked that. It’s not updating in the ST IDE. I’ve just had a look through the logs and it seems to be complaining about the zip code. I’d put my UK postcode in there thinking it would be ok. Obviously not. I’ve removed it now and will see if that helps. Should update again in about 20 minutes.

As @josh mentioned in the earlier post, some UK users have reported issues with Weather Station, and I remember some had success using geolocation (latitude and longitude) in the zip code field. Have you tried this yet?

It sounds like a number of UK users have been posting in the SmartThings community that SmartWeather hasn’t been updating for them recently.

Hi James

I just tried that. I did it earlier today and I suspect it’s killed it. It seems to read the last known values and then doesn’t update if you have anything in the location box. I’m going to keep an eye on it for a few hours to see if the temperature changes later this evening. It’s close to the Netatmo app, but not exactly the same. It could be a rounding issue, or it could just be slight differences in where it’s reading from.

1 Like