Variable based timer

I have 3 timers that are variable based. A 1 minute timer, a 5 minute timer, and a 45 minute timer. They have worked great since the beginning. This week I noticed some things were not working as designed. (things that are triggered by a timer).

After digging into it I discovered I had no recent logs for the 1 minute and 5 minute timer, and the 45 minute timer had logs and was doing its thing. It turns out that the 1 and 5 did not trigger for more than 3 days.

When I created these timers, I also created a rule that would alert me if the timer stopped working. Basically, if the variable had not changed in a predetermined amount of time, send me a notice. (I didn’t get a notice from either of the rules that were not working.

Here is the rule for the five minute timer. Others are the same except the time is different.

Here are the most recent logs after I restarted the timer.

Here is the rule that is supposed to send me a notice but did not.


Is there a better way to do this (create a timer)?
Is there a better way to get a notice if it is stuck?
Is it possible that a 1 minute and 5 minute period is just too short, the 45 minute has never NOT worked?
Is it possible a re-authorization could stop the timers? I did one about that many days ago. (I would not think so…)