Tile to override a rule for 5 minutes

I have a rule set up to trigger a chime when a door or window is open. Is there a way to create a tile to override that rule for 5 minutes and then automatically toggle back so that the override is no longer active? For example, would like to go to garage at night without triggering the chime.

You could use a true/false variable to do this. Create the variable, we’ll call it $override, set it to false.
Create a rule with a Trigger of $override stays true for 5 mins, Action set $override false. Add that variable to a dashboard so you can toggle it.

Then in your original rule add an IF condition to check if $override is false then play your chime else do nothing

2 Likes

Thank you. This did exactly what I was trying to accomplish. The only issue I am having is that the chime is partially firing before the “else condition do nothing” takes effect. I thought about delaying the chime upon door open, but don’t see that option, to allow time from the logic to catch up. I do not have a hub (although one is in the mail). Is this just a latency issue?

It sounds like it could be. You can try switching the order so that if $override is true do nothing else do all the things or maybe add a 1-2 second delay as the first action and see if that helps.

That’s strange, it should check the variable before going further in the rule. So it should not start running and then bump into the condition and stop.

Can you post a screenshot of your rule? When you tap the menu button at the top of your rule, there is a screenshot option.

2 Likes

I tried adding a delay of a few seconds. That didn’t work. I have now tried to flip the logic’s to test for true first but both conditions trip the chime.

Is something else triggering your Chime? For example, a routine in SmartThings?

If your $chimeoverrid [sic] is active, then this rule would go to the ‘Then’ path and turn the siren off (after 2 seconds). So I’m not sure I understand how the chime is being activated?

I did have the chime triggering in SmartThings. I turned that off but still chirped. I then flipped back to the original “false first” logic and removed the else which was programmed to turn chime off, it now works. I misinterpreted Terri’s “else do nothing” as “turning chime off” vs simply leaving that part blank. Thank you all for the help.

3 Likes