Thermostat issues with Hubitat?

Greetings peeps,

I’m in the process of migrating my devices from Smarttings to Hubitat. Of them 3 are NEST thermostats. They worked well with Smarttings and SharpTools. After bringing them over to Hubitat, SharpTools doesn’t seem to properly reflect each thermostats status correctly. One is stuck on cooling and the other two are stuck on idle. In both platforms I’m using “MyNextManager”… which is working spot-on.

I can control them though Hubitat and any change is immediately (like in literally 1 or 2 secs) picked up in the Nest android mobile app… but not in SharpTools. Has anyone else encountered this issue?

Any advice would be appreciated. :slight_smile:

EDIT: When I change themperatures in Hubitat, BOTH SharpTools and Nest mobile app show the new temperature setting… just not reflecting the actual thermostatoperatingstate.

Work thermostat is not reflecting when cooling turns on
Screenshot 2022-08-31 113818
Screenshot 2022-08-31 113745

Home thermostat is stuck in cooling
Screenshot 2022-08-31 113835

After change… still shows cooling when it should be idle.
Screenshot 2022-08-31 115356

Were these devices only recently added to your SharpTools dashboard as Thermostat tiles? If so, the first thing you might try is to refresh your browser page while viewing the dashboard. It will kick off a set of health checks in the background that can often clean up event subscription issues.

If that doesn’t help, can you share the Doc ID of the device(s) in question that aren’t updating the operating state as expected?

1 Like

Thanks for the fast response. :slight_smile:
Yes… I’ve tried a few few page refreshes on several devices ending with the same results.
If I may ask… where would I find this DOC ID?

  1. Open your User Page
  2. Tap the ... next to the location in question
  3. Scroll down and tap on the device
  4. Flip the ‘Advanced’ switch in the top-right corner on
  5. Copy the Doc ID

Hmmm noticed most of the attributes are greyed out.

That normally means that there isn’t an event subscription. For the first one, I’m only seeing humidity, temperature, and thermostatSetpoint subscribed. :thinking:

Sending you a PM to gather more details…

I have the same issue (can set temp, but wont update mode or current temp)… if its something we can fix, can post the solution here. Thanks in advance.

We pushed a hot fix for this earlier this evening. Refresh the page showing your dashboard with the thermostat and it should setup the required subscriptions for mode, etc. If that doesn’t help, feel free to PM me as you may be experiencing something different.