Thermostat Info Not Syncing

Hi all,

Over the past year, I’ve had an issue a couple of times where my ecobee thermostats disconnect from Smartthings and the sharptools dashboard displays the last information available while they were still connected. Usually, going into Smartthings and re-authorizing it to access the ecobee service resolves this and the thermostat tiles in sharptools display accurate information once again.

The last time the service needed to be reauthorized in Smartthings, it didn’t resolve the issue in sharptools. I can now see accurate thermostat information in Smartthings, but the sharptools dashboards all show the out-of-date information. I’ve attempted to remove and re-add the thermostats under the Manage Connections menu > Authorize SharpTools to access your Works With SmartThings devices, but that hasn’t helped. Anyone have any ideas?

Just to confirm, are you saying you tried reauthorizing starting from the user page → Manage Connections → SmartThings flow?

yes, that’s correct. I’ve even removed access (unchecked the two thermostats), saved, then went back in and reselected the thermostats again and saved.

@Paul_I, did you happen to delete the devices in ST and reconnect Ecobee? (ST might have created new thermostats for you if that was the case.) Just wanted to make sure the thermostat tiles you have in the dashboard(s) are linked to the “right” devices in ST.

@James yes, that’s what it was! Somehow in my list of “things” (in sharptools, not Smartthings) I now have 2 sets of thermostats with identical names. How do I delete the old ones from the list?

Have you checked if the duplicated devices are shown in the device page in the SmartThings IDE site? Might be easier to lookup in there and delete the old ones, than trying to find them in the ST app.

1 Like

@James That worked! Thanks!

1 Like

My ecobee has also lost sync with sharptools. Mine is connected to Hubitat. No events come through from sharptools, but Alexa commands work. I’ve tried reauthorizing in sharptools. Don’t know what else to try. Any suggestions?

Hi @Stan_Silverman, does your Ecobee update as expected in both Hubitat and Alexa? Can you pm me its doc id so I can help take a look? You can find the device doc id by tapping the ... next to your location under the Authorized Locations, select the Ecobee device in the list, and toggle the Advanced switch to show the Doc ID as shown in the screenshots below.