Tasker, SharpTools, SmartThings & SimpliSafe Alarm

I have a Samsung ST hub. I also have a SimpliSafe Alarm. I have an app in ST that controls SimpliSafe. SharpTools is connected to SimpliSafe as well thru the ST hub. In Tasker, I use SharpTools in a task to turn the alarm on and off. However, it is not working well. When I run a task to turn on the alarm, it takes about 10 seconds. When I run a task to turn off the alarm, it doesn’t ever seem to turn off. I’ve waited 30 seconds or more and nothing happens. I have to then go to the SimpliSafe app to turn it off (or use the keypad). Anybody have any suggestions on how to get this to run faster? I am using both the Class and New ST apps if that matters. This was all working fine until this year. Not sure what changed. Thanks.

@Richard_Belthoff, have you checked the the app’s log in SmartThings when the task ran? Trying to understand where the issue might have occurred?

Which app are we talking about? ;-). I’ll try to turn on logging for all of them to see what’s going on. I’ve looked a bit earlier today, but didn’t see anything specific. I did ask about this over on the ST community because I also use the @rboy Lock User Management app and it’s not apply to turn off the alarm any longer, either. I even set up a WebCore Piston to do it. Everything runs. It just doesn’t actually turn off the alarm. I think there’s now a disconnect between ST and SimpliSafe. I know SS isn’t supported directly, but the SimplieSafe monitor app from tobycth3 that I installed in ST seemed to be working great until recently. Thanks.

2 Likes

I believe he was referring to the SimpliSafe SmartApp logs via the SmartThings IDE Live Logs.

For anyone else who finds this thread, there’s some additional commentary over in the matching thread in the SmartThings community.

1 Like

Got it. Been watching the logs. Everything seems to be working OK, in the log anyway. For some reason, if I set SHM to Armed Stay, SimpliSafe turns on shortly thereafter. However, if I then set SHM to Disarm (by pressing the “button”), SS doesn’t turn off. It’s like it’s not reading the change in SHM. It’s weird because I have routines to set SHM to Disarm in the morning, and when I run the routine, SS disarms almost immediately. Obviously, something is causing a delay somewhere.

2 Likes

Good progress! BTW, just to clarify that you were not using “STHM” in the new SmartThings app, right? Not sure where and what “button” you pressed to disarm SHM. The “STHM” in the new SmartThings app looks like SHM, but is a totally different application and is not accessible by any 3rd party applications.

In SHM, there are three ovals to press to arm or disarm. I called these the buttons. I do have the STHM in the new app installed as well. I know it’s not accessible by any 3rd party apps. At this point, I guess it just sets a security level for SmartThings and not much else. By the way, I was listening to the SmartThings API intro video linked over in the SmartThings community and the speaker mentioned the partnership with SharpTools. Some free publicity! Now if I could only get SimpliSafe to integrate directly with SmartThings…

2 Likes