Tasker Error - Thing: Get Attribute - Only One Switch

Hi, I’ve been getting an error for a while when trying to use the Thing: Get Attribute action in Tasker when trying to get the light state of a specific switch of mine. I have multiple light switches and bulbs in my SmartThings network, but only this one switch gives me this error.

12.06.57/ActionArgBundle key: locationID: replace String value with null
12.06.57/E FIRE PLUGIN: Thing: Get Attribute / com.twofortyfouram.locale.intent.action.FIRE_SETTING: 7 bundle keys
12.06.57/E Thing: Get Attribute: plugin comp: com.boshdirect.stwidgets/com.boshdirect.stwidgets.Tasker.FireService
12.06.57/E add wait type Plugin1 time 15
12.06.57/E add wait type Plugin1 done
12.06.57/E handlePluginFinish: taskExeID: 1 result 3
12.06.57/E pending result code
12.06.57/E add wait task
12.06.58/E Error: 2

Any and all help would be appreciated.

What do the logs in SharpTools say? These look like Tasker logs.

Yeah, that is a Tasker error. The sharptools logs have nothing. I have logging on, and I turned on and off the light, but nothing shows in the log, and when I try to send the log it crashes the app.

The light state shows up in the app, just Tasker cant seem to retrieve the on/off state.

That is odd. If you watch the SmartThings IDE Live Logs while you try to run that task, are there any clues?

Is that the exact same task you are using to retrieve status from other devices (using variables) or a separate task? If it’s a separate task, does it work when you edit it and change it out to one of the other known ‘good’ devices?

And have you tried creating a new simple task just for troubleshooting this? Just a single action to get the Thing State and the Flash it to the screen for verification. Do that for a working device and then edit the task and change it to your ‘bad’ device to see if the issue still exists?

Not entirely sure what you mean by “SmartThings IDE Live Logs”. If I check the history, it shows the device turning off/on bit that’s about it.

It is the same task, but different actions. I’ve also tried switching the device on the actions that work, and they always fail when set to this specific switch (kitchen lights).

So I just made a simple task with just the Thing: Get Attribute action and a Flash toast action. When set to the working devices, it doesn’t error, but returns a “null” value. It still errors on the switch I’m having issues with.

Anyone have any ideas? Still having this issue.

They’re live logs that stream from a special interface that you can access.

Unfortunately, they’ve made this a bit more complicated with their recent releases. You used to be able to go to a single URL and it would automatically direct you to the right shard. Now you have to:

  1. Login to https://graph.api.smartthings.com
  2. Click on My Locations in the top menu
  3. Click on your location name (hyperlink) in the left column

    Once you do this, the URL should redirect to the appropriate ‘shard’
    eg. https://graph-{XX}-{XXXX}.api.smartthings.com/location/list

  4. Tap the Live Logging option from the menu

If you don’t follow the steps above, you can get stuck on the wrong shard and the Live Logs will never show anything.

Thanks for the steps. I got in and this is what it shows when I turn the lights on then off. When I run my task to get the status of the lights, nothing shows in the logs.

Even for devices where the task is working as expected? :thinking:

Yeah. I ran my normal task which has all my devices. It goes though the working ones and then stops at the non-working one.