Super Tile Slow to Load

I have a super tile that displays 3 text values taken from a thing. However when the page loads it shows a big ? until the super tile is loaded. Is there any ways to speed this up?

Everything else on the page has been loaded except the super tile.

1 Like

Can you share a bit more context?

Is this when you are navigating from one dashboard to another (eg. within the web app) or doing a fresh load of a page?

Most of the standard content (things, media, etc) are pre-loaded together when the web app first loads. The Super Tiles and Custom Tiles are not pre-loaded, so they are loaded individually once the dashboard is opened.

When switching from one dashboard to another, all of the main content is already pre-loaded, so the only real network activity is to load the extra Super Tiles. In my testing, my Super Tiles are usually loaded before the dashboard loading animation has even completed.

But if I do a full page refresh (eg. F5) of a dashboard page, then it first has to pre-load all the various content and sometimes takes a few extra ticks as it’s also running various healthchecks. From some quick testing, sometimes that means the Super Tiles take 1-3 seconds for me to load.

This is exactly it.

This super tile is sitting on my main dashboard. So this dashboard is the first to load when I launch it on the phone. It does take 1-3 seconds to load. I guess its querying for the latest data on the objects on the tile which are just text attributes from 3 different things.

I created a feature request for it, so we have something to track it with.

I think there’s opportunity to cache the Super Tile layout, so it can load faster with a fresh page load.

Nerdy Details

This would be a browser side thing, so it would get cached on first load and then would be fast with future loads… and then if the cached layout differed from what ultimately gets pulled down, of course there would be a few seconds where the cached layout is displayed and then it flashes to the new layout, but I suspect that would be an acceptable scenario for most people.

3 Likes

Thats great Josh !!..In my case, always Supertiles displays by 3-4 seconds with a big “?” after dashboard is displayed… (iphones mobiles)…

It sounds like you might have the same use-case as @GavinCampbell where you are loading your dashboard directly on your phone (rather than navigating from dashboard-to-dashboard like a wall-mounted setup).

Feel free to cast a vote on the feature request above as well!

1 Like

Hi, I have both cases, “?” for Super Tiles in my main dashboard, and also “?” by 3-4 seconds in secondary dashboards my friend … (rest of the tiles, loads immediately)…

https://drive.google.com/file/d/1-sHPipZNCxvCHnVqe5wrAXq5QD3-lC3B/view?usp=sharing

Can you share more details about how you’ve linked to the Escenas dashboard and then back? In both cases, it looks like it’s doing a full app reload rather than doing a fast navigation between the dashboards.

Feel free to PM me or email support@sharptools.io with details if you prefer.

1 Like

Hi all Community. Change from “Open in a new window” to “Open in the same window” setting, totally changes open performance of dashboards, Supertiles do not displays the “?” sign … Thanks for your guidance Josh !.

1 Like