[Solved] Zigbee Peanut Plugs on Hubitat


#1

Ok, here’s something I noticed today. I have 3 Securifi Outlet Plugins around the house linked to Hubitat. After adding them to my SharpTools Dashboard I have no control or status updates on them. I can turn them on and off through Hubitat with no issues but SharpTools doesn’t seem to reflect any status changes?

Note: They are all using the Generic Zigbee Outlet Device Driver


#2

@Mark_B can you control them with SharpTools as well, but just can’t see the status updates?

Edit: Can you also confirm your specific Hubitat firmware version?


#3

Latest: 2.0.6.112

Honestly can’t say if they were working prior to the new 2.0.6 update since I never really paid attention to them in the past. lol


#4

Interesting. So they were authorized with SharpTools before you completed the 2.0.6 Hubitat update… just not used in a dashboard? If so, they should have been setup with the default subscriptions under the legacy model.


#5

Hmmmmm…That’s a good question, let me remove one of them and re-authorize and see if that makes a difference.


#6

Thanks. Once you’ve re-added it, can you confirm if you can control either the existing one or the newly reauthorized one from SharpTools?

Another user reported that they can control new devices added after the 2.0.6 update, but the event subscriptions don’t appear to be getting setup for them.

Edit: What’s interesting is it sounds like the dynamic event subscriptions were at least working at one point after the 2.0.6 update as your weather forecast icon and weather status are updating if I read your post in the APIXU Hubitat weather Tile thread right.


#7

Ok, so I removed one of the Zigbee Plugs from the Dashboard, then removed it from the authorized list. After that I reauthorized the plug and added if back to the dashboard as Master Bedroom (see below), however it still does not update the status or control the plug on any of the 3 plugs I have, whats odd is that one of them does show “Off” while the rest are blank, but you can’t control the “off” one either. Everything else is working just fine, it’s just these 3 Zigbee plugs.

plugs


#8

It’s this plug, right?

I have one of these at home that I had left on SmartThings for testing… assuming I can find it (we just moved), I’ll connect it to Hubitat and see if I can reproduce the issue.

The fact that only one of them shows a status is also interesting. Behind the scenes, SharpTools uses a virtual method called toggle() for most switches. That method basically just says, if the switch is ‘on’, then send the off() command otherwise send the on() command. Have you confirmed that Hubitat is properly reflecting the ‘switch’ state for these devices?


#9

That is the plug! I can’t confirm that the current state is correct or not (actually I thought the current state was removed in the newest update), since I’m not at the house at the moment. I’ll have to update you later on that. I just tested the switch in Hubitat by turning it off and on through the dashboard commands and seeing if sharptools responded to the changes since it wasn’t updating through my dashboard input. I’ll let you know.


#10

Ok update…While monitoring the hubitat command tab, i was able to verify the current states do update. However Sharptools dashboard does not update the state unless you hit refresh in the Hubitat commands. For example if i press the tile in Sharptools, the command is sent, but no update happens until I refresh the outlet in Hubitat. Also, when controlling the plug through hubitat, nothing changes in Sharptools until a command refresh is sent.


#11

Thanks for the update. I’ll see if I can find my Peanut plug and reproduce. :smiley:


#12

Ok, so the mystery continues…I got to thinking: What would happen if I switched the driver from a generic zigbee outlet to a zigbee switch, I know it will still basically function on/off the same. So I removed the tile from the dashboard, de-authorized the plug in Sharptools, changed the driver to a generic switch in Sharptools and reauthorized it and created a new tile. Guess what? It didn’t work…BUT when I went back into Hubitat and changed the driver back to an outlet (without re-authorizing it) it started working?!

So I thought, well maybe I stumbled onto something, and repeated the exact same process with another problem outlet. Same process = different results. No change.


#13

SOLVED! Not sure why but I needed to hit the “configure” button in the device driver of Hubitat in order for it to function correctly with SharpTools, all three are working correctly now. Thanks for your patience with me!


#14

Thanks for the update and for posting your solution! I had just found my plug and was going to try to reproduce. :smiley:


#15

For what it’s worth, I was able to reproduce various issues with the Securifi Peanut plug on Hubitat.

Hubitat discovered the Peanut plug quickly, but didn’t associate a meaningful device driver to it. It was just left as the generic device after pairing it. (eg. it had no commands, no state, etc)

After changing the driver to Generic Zigbee Outlet, the commands for turning the device On / Off came available and whenever I pressed them, the device would turn on/off accordingly, but the state never showed up in Hubitat and no events showed up in the device event history in Hubitat.

That being said, I think this is somewhat the expected result. If I remember correctly, the configure command of a device driver is automatically run when a device is first paired, but is not run when you manually change the device driver. So because the Peanut Plug wasn’t recognized with a meaningful driver, it never ran a configure command.

Thus, manually running the configure command on the device effectively completed the final required step of the pairing process and got the device communicating its status back properly.