Solved: Unable to login in to community or dashboard


#1

I would like to set up a dashboard on an old Motorola Xoom running Android 4.4.4 (rooted). Running last version of chrome for this device (version 31.0.1650.59). I also tried fully kiosk with the same results.

I am unable to login. Whether I chose Google, email or phone I get the following screen and nothing else. Anyone seen this before?

The device is probably too old to use but thought I would ask before giving up.


#2

I’m looking into it. I was able to reproduce on an Android 4.4 emulator in the stock browser. While the Xoom is a pretty old device, I’d still like to see if I can get it working on Android 4.4.


#3

Thanks Josh. The thing is built like a tank. I hate to part with it. It has been working well as an “automation tablet” but ST classic does force close occasionally and ST connect isn’t supported. I did set up a bunch of widgets for my most used devices so I have a work around.

I did try a handful of browsers that I could actually get to run on it and they all exhibited the same behavior.


#4

Hey Josh,

I got it working. It seems to be caused by chrome being so old. I suspected that when I saw a warning in Fully Kiosk about webview being out of date.

I found and installed “chromium for tegra 2” from XDA and was able to log in. This version of chromium is at version 70. I am including a link to the XDA thread in case someone else runs into this issue with an old Tegra 2 device.

I know side loading software from sources other than Google is a security risk but, if your working with a rooted device like the Xoom, you should probably already understand this risk. If you feel the link is inappropriate, please delete it.

https://forum.xda-developers.com/devdb/project/?id=19227#downloads


#5

Thanks for the update and the workaround! I spent some time working on this and made good progress. The stock Android 4.4 browser is missing a bunch of modern features we are using, but I was able to shim each of these features and get things working in the dev build. :slight_smile: Assuming I don’t find any glaring issues, we’ll likely include this in an upcoming release.


#6

@Josh is freaking awesome!


#7

The changes are live now and the things should work on Android 4.4 now. :slight_smile:


#8

Thanks Josh. The Xoom started locking up and it seems to have started after installing Chromium. The old version of Chrome is now logged in and working.


#9

Spoke too soon. The dashboard displays but when pushing a tile I get “Error Sending Command”. I’ll troubleshoot it in the morning.


Kindle Fire, Fully Kiosk, Error Sending Command
#10

@josh. I tried logging out and logging back in. No go. I also checked my devices subscriptions and that fails too. Chromium is working as it should with the dashboard.


#11

Thanks for the details. Sounds like we made good progress but there are still a few things to check. I’ll fire up the emulator next week and do some further testing.


#12

Today’s platform release includes some additional enhancements around older Android devices. Let me know if this fixes the errors you were seeing when tapping a tile on your Xoom (in Chrome).


#13

I’ll check when I get back to the house this evening.


#14

Seems to work perfectly. I tried on/off, dimmer, and my Honeywell thermostat using tile confirmation. No issues. Thank you!