SHM Status - push notifications? Sound?

Good catch @josh.

I just tried @David_McNae’s mp3 file in Dropbox, and that appears to be working properly.
So I uploaded the file to dropbox’s public folder, and generated a link like this.
Dropbox - Police Siren Sound Effect (1).mp3 - Simplify your life

And I had to replace host name and url parameter to this to get the direct file download url.
https://dl.dropboxusercontent.com/s/nz4q7ikaaim66gz/Police%20Siren%20Sound%20Effect%20(1).mp3?dl=1

That works beautifully. :slight_smile:

2 Likes

Perfect thank you. Will give it a shot.

1 Like

HI, @josh @James i am testing out the trial so far loving it!!! clean and very user friendly and fast!!

I am setting up the konnected Alarm Panel and therefore replacing my old alarm keypads, i am trying to accomplish something related to this thread…

I had set up a delay for a about a min when entered via the front door to give time to disarm via the tablet. but my wife and i would like to hear a sound from the tablet it self so we remember to disarm it within the minute (like traditional keypads do)… we dont always see right away our phone alerts or push notification… so is there any solution to this without the need to install a sonos speakers system or another smart speaker… i local sound file on the tablet would be the best option…

let me know what you think the best option for me. thanks

Thanks for the feedback and glad to hear that you are enjoying things. What kind of tablet are you using to display your dashboards?

If you’re using a Fire Tablet or Android Tablet along with Fully Kiosk Browser, you could use that with SmartThings (DTH) or Hubitat (driver) to play a sound. The integration has a variety of neat features like commands for beep(), chime(), alarm(), and playSound() which might be helpful to you. Each of these commands can play a local sound file stored on the tablet.

Thanks for the fast response!

It’s Fire tablet. So the options are available via fully kiosks features? Because I wasn’t able to figure it out through the Smartthings DTH alone.

Check out the posts linked above which provide a Fully Kiosk Integration for either SmartThings or Hubitat:

These integrations expose your Fully Kiosk Browser tablet as a device in your smart home platform. You can then setup rules either using the built-in rule feature of your smart home platform or using the SharpTools.io Rule Engine to access the custom commands on your new Fully Kiosk Browser ‘device’.

Thanks @josh!! Will give it a try tomorrow. Thanks

1 Like

I have also tried this option and have failed. I can see my tablet created in SmartThings but I can’t get it to do anything. If any one has been successful this would be big since no one bothers to check if the SHM is active.

@Ryan_Mclellan, can you share your device’s preference settings so we can better understand where the issue is? See screenshot below for my Fully Kiosk device settings.

You can test out if the device in SmartThings is working properly by using the following mp3 in the “toneFile” field, and tap the Find sensor’s play button in the SmartThings app. If your tablet plays a ring tone, then it means the device in SmartThings is setup successfully.

https://www.dropbox.com/s/bh1cm7gk1cjm9hb/bell.mp3?dl=1

1 Like

I followed the steps again like in the above guide for smartthings. My device has more options then yours. Set up the IPs to match what I have for my tablet. I added in the dropbox file like you had in your image. I’m still not able to make it make a sound

What device handler are you using? It seems to be different from what I used, the one posted above.

https://github.com/arnbme/fullytts/blob/master/devicetypes/gvncampbell/fully-kiosk-browser-controller.src/fully-kiosk-browser-controller.groovy

It doesn’t have the extra preferences as shown in your screenshot.

I just copied the one our listed. created a new device with this device handler. Still not doing anything. Anything extra that I may be missing on the fully kiosk side? I selected the setting mentioned in the document and have fully access that it requested after the changes were made.

Here are the step-by-step instructions that you might be interested. Let me know if this helps and if you are able to hit the Fully’s admin page from your browser once you enabled the Remote Admin feature in the Fully Kiosk’s settings.

Yes i’m able to log into it remotely via web url. would the App version be an issue. Looks like I’m running a newer version then what you displayed. Also I looked at the doc again and it looks like I would need to have the .MP3 file stored locally on the device in order for it to play. I noticed that others with similar issue did not have anything installed and yours displayed the URL to a dropbox link. what would be the correct option?

Hmm… I don’t think the app version matters here, but I could be wrong. :thinking: I will test out the same version app when I have a chance. The toneFile is not required for the setup, and I was suggesting it just for the troubleshooting purpose, so you can tap the play button in the SmartThings app and see if that can successfully ask Fully to play the ring tone.

Meanwhile, a few troubleshooting thoughts:

  1. Can you verify if the tablet, where the Fully Kiosk Browser is installed, is in the same local network as the SmartThings hub?

  2. In ST app, go to this Fully Kiosk Browser device you created, and change the Logging Level to “Debug” in settings. Open SmartThings IDE → Live Logging, and tap the “play” button in the ST app, and take a screenshot of your log. Do you see the command was sent and received a 200 OK response?

@Ryan_Mclellan, fyi I just updated Fully to 1.42.5-fire, and the SmartThings integration is still working good for me.

I think I might know my answer. Since I’m using a fire 7 and wanted to limit the used resources to help speed it up. I skipped the Amazon registration. With out doing this Alexa was not installed. Not sure if this option make the TTS work. Either way I was able to remote log into Fully from web browser and was able to get a screen shot, camera shot, display a written message on the screen, turn screen on and off. The only this that was not working still was the TTS option. I’ll try and register the tablet to get Amazon and also verify this with my fire 10 tab.

As a side note I have been playing around with Home Assistant and it’s going pretty well. I’m able to integrate a lot more things then with Smarthings alone and devices seem to run much faster since they are not passing around on the cloud

1 Like

This is great. Opens up a lot more possibilities. Does anyone know if there is a way to close an app?
e.g. you use ‘Launch App Package’ to open one but when your done is there a command to close the app? i see that you can use the ‘Bring Fully To Front’ command but some apps continue playing in the background so need to be closed.

Are they audio/video type apps? It looks like the Fully Kiosk Controller driver exposes the stopSound() command. There’s also a stopVideo command available via the Fully Kiosk API but it doesn’t look like the driver exposes it – if you need that command, you could add a feature request in the FKB Controller driver thread asking for it to be added?

Hi yeah its video. E.g if I open YouTube or the local streaming TV app. When I bring Fully to the focus YouTube keeps going and minimizes itself as an overlay.
I contacted the Fully guys to see if they have any ideas.
thanks

1 Like