SharpTools HA Add-on stuck in Authorisation


I’m running HA in a docker container (Frontend 20230705.0 - latest) on a QNAP NAS and I’ve been using the containerized SharpTools add-on with it for quite some time (sharptools-hass-addon-connector-i386:latest). I had to move the NAS and restarted earlier this week, but I couldn’t authorise the add-on as before. It gets stuck in the second step. After I select the entities it keeps processing, never goes through to the synchronising step:

Everything shows up in the green, but there’s no actual connection. The entities do not update within SharpTools:

I restarted all, several times, but couldn’t get any further. Nothing else changed in the network that I could suspect interfering.
Could you please help, what else could I try? Let me know if you need any further info, diagnostics or anything. Thank you very much in advance!

Kind regards,

Thanks for posting and sorry to hear that things aren’t working as expected. I just pushed out a hotfix based on an error I was seeing in the logs for your authorization attempt. Can you give it a try again?

I tried again, it worked like a charm. Thank you very much for the lightning fast fix!

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.