Sharptools and Total Launcher issue

im setting up an android pad and have total launcher installed as one of the features lets me add an image then on Tap lets me add an action, when i set this up and select the action it gives me 3 SharpTools “widgets” one being a thing, i select this and sharp tools opens up and lets me select what thing i would like and how i want it to behave. This is all fice.

When i go and test this and tap the image it bugs out slightly while it does the thing i asked, in my test case turn on and off a lamp it also tries opening another random app, i have tested this on an old android pad i have and works fine on my Samsung tab has this strange bug.


To edit thisits actually not triggering a random app its ghost pushing the android back button

Can you think of anything different between your two tablets or the configuration of Total Launcher within them? And have you tried reaching out to the Total Launcher developer?

Alternatively, I remember somebody doing something similar with Total Launcher along with Tasker and the SharpTools plugins. Perhaps you could try that approach?

So I have just tried another launcher added the same sharptools Thing shortcut and getting the same result

Have you tried the Tasker approach?

Shortcuts vs Widgets

Note that Android Shortcuts technically launch apps. So If you are using the blue shortcuts, they technically launch the SharpTools Android app invisible and immediately close the app.

The widgets that display state (grey/yellow) are traditional Widgets that use native Android widget features to communicate in the background with SharpTools.

Tasker communicates more like a service in the background and is better suited for custom launcher interfaces like this.

I hadn’t has have no idea how to achieve what I was doing plus just purchased the widgets add on now the tasker one plus I’m guessing I need tasker as well.

Guess back to researching and going tasker route

got it to work the way i wanted with Tasker,

Thanks for the help.

1 Like

Thanks for the update - glad to hear you got it to work the way you wanted!