Scrambling Dashboard on Save

I was making a minor tweak to one tile on one dashboard. When I saved the dashboard all the tiles moved to new, scrambled locations. I have tried over and over to fix this but it just keeps happening. I even rebooted my computer. I simply can not save this dashboard in the intended layout anymore. It worked just fine for a week or so.
I have tried this in Chrome, Brave (same as chrome) and Edge. All with the same result.

Welcome to the community and sorry to hear that things aren’t working as expected. Would you mind sharing a screenshot or video of what things look like before/after?

HI Josh. Suspicious about the possibility of a Windows update issue I went to a laptop I don’t normally use for SharpTools. It too runs Brave. I was able to log on to Sharptools and repair my dashboard and save it successfully. After that I went back to my desktop and could see that there were updates pending so I went ahead and ran them but I have not been brave enough to go back in and see if I can edit a dashboard yet. I will do that and report back to you. Bottom line, this appears to be windows 10 related. (Wouldn’t be my first time…)


After Updates on my desktop was able to modify and save a lesser used dashboard OK. Went back to the one I was originally having issues with and it scrambled again as before. When I was in the process of getting you before and after screenshots it stopped doing it. Not sure what to think at this point. Will play with this more the first of the week and advise if I learn anything helpful.


Closing Comment: Today I was able to modify and save any dashboard without the scrambling issues described. As best I can tell there was a Windows 10 update that did not properly finish and was waiting to restart. After I manually restarted it and let it complete things started working OK again. So this was apparently something unique to the status of my desktop computer and is now clear.

Thanks for the update, @waltdews!

If you see the issue again, would you mind taking a screenshot of the ‘after’ effect with the tiles being scrambled (ideally while still in edit mode if the tiles scramble before tapping save).

Will do. I can tell you however that they only did the scrambling when I hit the save icon.

I do find that tiles often act a little squirrely when I am trying to arrange them the way I want. I just figured that is my newness at this. I have always been able to get them where I want them eventually.

My hunch is that it’s trying to render based on the layout (vertical tablet, TV, etc) you selected when creating the dashboard.

I ran into the same problem today, and I think it might help to be able to change the layout in the configuration. (if it’s there, I missed it)

If you experience an issue with your tiles getting scrambled on save, can you please share a screenshot (or better yet a video if it’s reproducible)?

For me it wasn’t so much jumbled, just not the exact layout I had set because I think it’s trying to render eg a landscape layout I wanted into a portrait layout I had originally set when creating the dashboard.

If you’re using the Reflowing (legacy) dashboard layout, the tiles will reflow based on the width of the screen. If you’re using the newer Scalable dashboards, they should automatically scale to fit the width of the screen (eg. a fixed number of tiles wide).


Feel free to PM @support or send a note to if you’d like us to take a closer look with you. :slight_smile:

1 Like

I’m also now having a heck of a time keeping tiles where I want them. Also seeing quite a bit of shuffling when saving.

Not quite sure how to show you what’s going on, maybe taking a video?

@N_J_H, yes, a video would certainly help. Did you notice a certain pattern how to reproduce the issue, and if you can reproduce this same issue on a different browsers, or at different window size? Thanks for sharing the info to help us investigate.

It might take me some time - trying to get a new dash laid out and it’s a bit like playing Jenga :slight_smile: I’ve found I can delete everything and then try to add one thing at a time, put it where I want, and that seems to be helping a little.

More later if I lose patience :slight_smile: Using Chrome browser, and laying out a dash for a Fire HD10.

I’m having the same thing happen - frequently. I’m not sure when the problem began - seems like within the past month or two. If I modify a tile for any reason, the first Save will likely scramble the tiles. After repairing the layout, additional Saves are fine.

I’m pretty sure I can make this happen “on command” and will see if I can get some before and after shots to send.

My layouts are of the legacy era.