Rules not working after migration

Ever since i was prompted to do the migration a couple weeks ago my rules are not firing like they should. I have a simple rule to send a Pushover every time one of my door sensors opens. Smart Things shows that the door opened/close but i never get a Push. I added a HTTP trigger along side the sensor and that fires the push fine so it’s not on the Push Bullet side. I noticed in my other room the same thing with my rule to turn on a fan when vibration was detected on one of the sensors and that stopped working as well. I reauthenticated the Smart Things connection but no change.

Hi @Jamie_Poindexter - thanks for posting and sorry to hear that things aren’t working as expected. Did you have any errors during the migration process? The reason I ask is it looks like your account is missing the various event subscriptions that are necessary for rules to trigger.

To manually fix this, you can do the following for each rule:

  1. Open the rule for editing and make note of the SmartThings Thing triggers
  2. Remove those Thing triggers and save the rule
  3. Reopen the rule, add the Thing triggers back, and save

Thanks, that worked. I tried that before but didn’t save the rule between removing and adding it back

1 Like