Rule fires just once -- Help requested

I just installed a new door sensor (simple open and close). It is connected to my Smartthings hub, works well with Google Home/Assistant, etc. I set up a rule in SharpTools that when the Contact Status is “open”, send an SMS. It worked smoothly the first time. But, now, it doesn’t seem to fire to send the SMS again. Is there something in the logic I need to do to have it send a text every time the status changes from Closed to Open??

Thanks for the post. Can you share a screenshot of your rule?

Based on the description, I’m assuming there is a single trigger for contact is open and a single action for send SMS? Are there any other conditions or items in the rule?

Have you verified that the contact is switching back from ‘open’ to ‘closed’ as expected (eg. In a SharpTools dashboard)? The trigger event will only happen when the value switches from open to something else and then back to open.

Thanks for the quick response. I’ve attached a screen shot. I note that in my Smartthings app, it changes from open to closed and back almost instantly when I open/close the door. But, in the Sharptools app (on my phone and on the web) the status never changes.

@james i’ve recreated his rule and I’m seeing similar results where the rule fired the first time and isn’t firing after. Thoughts?

Edit: And thanks for sharing the screenshot. I removed it since it had your phone number in it, but the rule was setup as expected.

Hi Casey,
Thanks for reporting. It seems to be a potential bug that we introduced from the most recent updates. :frowning: We are looking into this now, and will keep you updated.

Thank you for the catch on my cell #. Like everyone else, I get enough unwanted calls. :slight_smile:

And thank you for your assistance. I like the dashboard and rules engine and would like to continue to use it.

I note that it worked correctly once this morning when I tested it, but not again. So, it looks like it will successfully work once per day.

Thanks for the update. We’ve found the issue and are working on a hotfix. :slight_smile:

Hi Casey,
We have just rolled out the fix. The issue should have been resolved by now. Please go ahead to give it a try and let me know if you still experience any issue. Again, thanks for reporting & updating. :slight_smile:

1 Like

The fix worked as you described. Thank you!