Rule engine automation not triggering

Hi all,

I’m new here. After 2 days testing and reading I finally ask the community so, hopefully I can be pointed in the right direction.

The rule should just send an email when a ST sitch virtual device changes to on. However, the email is not sent and the log is empty.

What am I doing wrong?


Hi @Fran_Lopez, welcome to the community. That sounds the rule wasn’t get triggered. Can you verify in SmartThings mobile app if the virtual switch was actually reporting state change events in the History tab? If so, try refresh any page in, which will kick off the event subscription health check and repair if necessary.

I’d also be happy to check the rule for you. if you can PM @support the url of when editing the rule.

Hi @James ,

Thanks for the quick response. The device reports the change. As you can see, it has several attribute and I have tried all of them.

I have refreshed the connection with ST and still no luck

I’ll PM @support right away.


Just a guess here, but it looks like the device in ST is a contact sensor (that reports open and closed). But the rule engine is looking for an “on”, not an “open” or “closed”. That’s strange, because my contact sensors’ Contact, Changes To prompt for open or closed. Not sure how you derive an “on” condition from a contact sensor.

I’m using a virtual device, that’s the reason for different attributes.

The issue was that the smartapp in ST was paused. I don’t know how that happened because I have never accessed that smartthings IDE page but thanks to @James is solved now.

1 Like